[mrtg] MRTG with RRDcached tuning

Pavel Ruzicka pavouk at pavouk.org
Wed Aug 1 11:18:52 CEST 2012


>     -s mrtg -m 0660 -l unix:/var/tmp/rrdcached.sock -l mrtg.auckland.ac.nz
> -l localhost -z 60
>     -p /var/tmp/rrdcached.pid -t 4 -j /u01/rrdtool/journal -b /u01/rrdtool
> -w 1800 -O -a 6

I tried -w 1800 and -z 60, but it still doesn't solve massive pdflush.
I don't understand exactly -z option. I understand from documentation
that when I set -z to 60 seconds, that it set random write delay between 0 and 
60 seconds. When I have -w for 1800, that rrdcached writes files to disk in 60 
seconds and -w option is not used. Is it true?

> This has had a significant improvement on our previous IO problems.
> For the frontend, you could use Routers2 (which supports rrdcached directly

I can't change easily frontend for historical reasons :-)

> :).  However, if you prefer to use 14all, then you can still do this via
> rrrdcached, at least  if you are using Apache.  Just set the
> RRDCACHED_ADDRESS environment variable appropriately in the web server so
> that it is set when the CGI is called, and this will make the 14all calls
> all use rrdcached, where possible.
> <Directory "/u01/www/cgi-bin">
>    SetEnv RRDCACHED_ADDRESS unix:/var/tmp/rrdcached.sock
> </Directory>

I tried it, but it probably doesn't use rrdcached. How can I check it?
I have on graphs white space on the side. It looks like 14all.cgi use not 
updated rrd file.

> You might want to consider using the trunk version of rrdtool, since this
> has more comprehensive rrdcached support for the various rrdtool functions.

I prefer to use stable version, if it works.

Thank you very much for answers.

Best regards,

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.oetiker.ch/pipermail/mrtg/attachments/20120801/c022ca69/attachment.htm 

More information about the mrtg mailing list