[mrtg] pulling snr data error

MMartin at jwpepper.com MMartin at jwpepper.com
Wed Jan 18 15:42:43 CET 2012


        "do you get a good answer from this query?
        snmpget -c test -v 1 .­
        snmpget -c test -v 1 .­"

I'm assuming that the space between the 10 and 94 is just is typo. But 
anyway there's is a few things I would try.

First try removing the "." that starts out the OID. That might help. But 
most likely that's not the problem.
Also, in you cfg file for the device. When you do version "2" on the 
"Target[_]:" line don't use the "c" I don't think MRTG recognizes that.

So for example, you would just use version "2" like this:
]:.­­. at
It should end with 5 ":" colons, followed by a 2.

This is from the cfgmaker man page:
                          Specify default SNMP options to be appended to 
                          routers following.  Individual fields can be 
                         Routers following might override some or all of 
                         options given to --snmp-options.

Also, your "Target:" name should be a unique name for each separate 
device/interface or you can think of it as for each separate graph. 
Because MRTG will use the target name as the filename for the RRD file.

One other thing you might try would be to telnet to the router and check 
out what the "snmp" or "snmp-server" settings are. There you should be 
able to see what the SNMP version is too.


From:   Lee Todd <ltodd2 at hallmark-uk.com>
To:     Ian <ian at acces.co.jp>, <mrtg at lists.oetiker.ch>, 
<MMartin at jwpepper.com>
Date:   01/18/2012 03:31 AM
Subject:        Re: [mrtg] pulling snr data error

Ian and  Matt

I can run snmpget and below is what I get from it

snmpget -t 1 -r 5 -m '' -v 2c -c test .
iso. = Gauge32: 72

snmpget -t 1 -r 5 -m '' -v 2c -c test .
iso. = Gauge32: 58

I have tried using -v 2c and -v 1 and both work

From:       Ian <ian at acces.co.jp>
To:         mrtg at lists.oetiker.ch,
Date:       18/01/2012 00:15
Subject:    Re: [mrtg] pulling snr data error
Sent by:    mrtg-bounces+ltodd2=hallmark-uk.com at lists.oetiker.ch

> I have been trying to pull snr data from a cisco 887 router.  I got a
> cfg from the web and changed what I think is correct but when I run it I
> get the following error.  Prob a really silly thing but im just not
> it.

do you get a good answer from this query?
snmpget -c test -v 1 .­
snmpget -c test -v 1 .­

mrtg mailing list
mrtg at lists.oetiker.ch

Registered Office: Bingley Road, Bradford, BD9 6SD

Registered in England no. 03414540

The information contained in this e-mail and any accompanying documents

may contain information that is confidential or otherwise protected from

disclosure. If you are not the intended recipient of this message, or if

this message has been addressed to you in error, please immediately

alert the sender by reply e-mail and then delete this message, including

any attachments. Any dissemination, distribution or other use of the

contents of this message by anyone other than the intended recipient is

strictly prohibited.

Unless specifically stated in this e mail, the agreement and content 

of this correspondence is subject to contract. 

No contract is implied by this correspondence, unless specifically 

stated as a contract (purchase order or sales order)

Think of the environment; please don't print this e-mail unless you

really need to

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.oetiker.ch/pipermail/mrtg/attachments/20120118/53db3776/attachment.htm 

More information about the mrtg mailing list