[rrd-developers] Re: Some minor changes proposal

Alex van den Bogaerdt alex at slot.hollandcasino.nl
Sat Oct 2 12:23:15 MEST 1999

> My reason for disagreeing with the "LST" alias, is the fact that it's
> not really a standard abreviation.  Simply having a TLA for every OP
> is IMHO not the way to go.  I can see the point to AVERAGE => AVG, as
> I'm a lazy bastard.  But how are you going to go with ROUND?  What
> about RANDOM?  Are they both going to be RND?
You got a point there however my reasons for "LST" are IMO different than
just have an abreviation. When debugging rrd_graph input it would be very
nice to be able to write:
    AREA:val2#FFFF00:"value 2"
    GPRINT:val2:MAX:"Max %6.2lf %sxxx"
    GPRINT:val2:MIN:"Min %6.2lf %Sxxx"
    GPRINT:val2:AVG:"Avg %6.2lf %Sxxx"
    GPRINT:val2:LST:"Cur %6.2lf %Sxxx\\n"
and not
    AREA:val2#FFFF00:"value 2"
    GPRINT:val2:MAX:"Maximum %6.2lf %sxxx"
    GPRINT:val2:MIN:"Minimum %6.2lf %Sxxx"
    GPRINT:val2:AVERAGE:"Average %6.2lf %Sxxx"
    GPRINT:val2:LAST:"Last %6.2lf %Sxxx\\n"
Furthermore, MIN and MAX are abreviated already...
It won't be necessary for RANDOM, ROUND and other RPN operators, it is
the consolidation function I was talking about.

> Also, I could make as strong an argument to not use "INT", but instead
> introduce a new operator called "#", which will give you the integer
> part of the number on the top of the stack [push(int(pop(TOS)))].  Then
> the above could be replaced with: "x,/,#" and "x,0.5,+,#".  This way
> keeping things in the same vein as other +,-,/,%,*,...  Of course, this
> would introduce a slightly non-standard operator, one I'd be quite willing
> to see not implemented...
Perhaps the other way around: Keep '+' and '-', '*' and '/' as they are
each others opposite. Use "mod", "int", "div", "frac" and others that
do not have common operators. '%' is then an exception for backward
compatibility. To avoid the discussion in the future: '!' could be
not (negate) or fac and should therefore not be used. Use "FAC" and "NOT".

Tobi, you wrote about the "INT" operator being more general useful. 
I do agree about that but I do think that if you only want operators
that fall in that category you should mention it now. I'm sure that
not only I will come up with other operators that are not-so-general :)

> Just my $0.03CDN worth...
My HFL0,05 (smallest coin over here :)

BTW:Nice to see so much response, it seems the list as come alive again

* To unsubscribe from the rrd-developers mailing list, send a message with the
  subject: unsubscribe to rrd-developers-request at list.ee.ethz.ch

More information about the rrd-developers mailing list