[rrd-developers] Re: Problem with perl (RRDs::graph) on XP, using Jun 10 snapshot

Calvert, Kerry kerry.calvert at intel.com
Wed Jun 12 01:42:11 MEST 2002


I have ActiveState  perl v5.6.1, build 631.  
I have Cricket(1.0.3) running using RRDTool version 1.0.38, so I believe my
perl environment is correct.
This is all running on a PIII with XP Pro and the .NET development

I took the Jun 4 development snapshot, and then the Jun 7 and 10.  They are
all the same, it doesn't look like RRD has changed since the middle of May.

I was in the perl-shared procedure (perl ntmake.pl, nmake, nmake test) when
perl crashed.  I changed base.t to add more debug output, which is how I
discovered that graph doesn't work. More on this in a minute.

Philippe.Simonet at swisscom.com suggested that I disable optimizations, so I
rebuilt RRDTool using the Debug configuration.  This did not work until I
fixed the lib pointers to match the release configuration and made the
run-time libraries consistent (all MTD). However, the behavior of the Perl
subsystem didn't change at all.   The perl subsystem doesn't have an easy
way to run in debug, or at least I don't know an easy way.  I will try to
change the makefile by hand to get a debug version of RRDs.DLL.   

Base.t creates a small RRD database and then tries to get a graph out of it.
I used the graph parameters from base.t to construct a perl script that ran
rrdtool.exe with those parameters, and I got a .png file that looks just
fine.  I also ran rrdtool.exe for INFO on the database. That produced a list
of values, but perl crashed when I tried RRDs::info in base.t.  

In the case of RRDs::fetch, I am not sure as to what I should be seeing, but
my results seem wrong.  I haven't tried rrdtool.exe fetch yet to compare.

I assume that others have got this to work on Win2000, so, for
troubleshooting analysis, I now think that the problem is in RRDS.dll as
compiled on my machine, under XP/.Net.  I noticed that the makefile seems to
be for vc++ 6.0, sort of, but I'm not clear on what to change.  I was going
to look at RRDs.xs and try to figure out how to introduce some debug code.

I would welcome any other suggestions.

 Kerry Calvert
 Software Sustaining Engineer
 Intel Corp.
 Hillsboro, OR
 kerry.calvert at intel.com

-----Original Message-----
From: Jake Brutlag [mailto:jakeb at microsoft.com]
Sent: Tuesday, June 11, 2002 11:48 AM
To: Calvert, Kerry; RRD_DEVS (E-mail)
Subject: RE: [rrd-developers] Problem with perl (RRDs::graph) on XP,
using Jun 10 snapshot


I did the work to get RRDs and rrdtool 1.1.x to compile and run on
Win32. I have noticed the graph command is unstable, but the crashes I
have encountered usually involve non-robust error handling (i.e. a CDEF
referencing an undefined DEF).

Is this test script you are running included with the rrdtool
distribution or perhaps a contrib file? If so, I could try to verify the
graph command crash you are seeing.

I don't have any insight on fetch; as you speculate it may be a bug
fixed in 1.0.x but post-branching 1.1.x.

Finally, are you using an ActiveState 6xx or 5xx Perl build?


Jake Brutlag
Network Analyst
TV Services -- Network Operations
Microsoft MSN 

Unsubscribe mailto:rrd-developers-request at list.ee.ethz.ch?subject=unsubscribe
Help        mailto:rrd-developers-request at list.ee.ethz.ch?subject=help
Archive     http://www.ee.ethz.ch/~slist/rrd-developers
WebAdmin    http://www.ee.ethz.ch/~slist/lsg2.cgi

More information about the rrd-developers mailing list