[rrd-developers] problem compiling cvs snapshot 2003-12-23

John P. Rouillard rouilj at cs.umb.edu
Sat Dec 27 01:02:44 MET 2003

Hi all:

I am trying to build the cvs snapshot from 2003-12-23. I am running
into a problem during configure, that is causing make to go off the
deep end.

The OS is RedHat linux 9.0. I have the following tool chain in use:

   autoconf - 2.59 built from source (version 2.57 available via RPM)
   automake - 1.7.9 built from source (1.8 built from sources also
              available)  (RPM version of 1.6.3 was too old according
              to MakeMakefile.) 
   libtool - 1.4.3 from source (same version available via RPM)
When I run configure, things look norma until:

  checking whether gcc accepts -g... (cached) yes
  checking for gcc option to accept ANSI C... (cached) none needed
  checking dependency style of gcc... (cached) gcc3
  checking how to run the C preprocessor... gcc -E
  ./configure: line 4633: AC_DISABLE_SHARED: command not found
  ./configure: line 4634: AC_PROG_LIBTOOL: command not found
  checking for egrep... grep -E
  checking for ANSI C header files... yes
  checking for dirent.h that defines DIR... yes

The rest looks ok. The resulting makefile then bombs out with:

    No rule to make target `cgi.lo', needed by `lib_rrd.la'. Stop.

Since the lo/la stuff is part of libtool, I assume the macros above
are an indication of the root cause.

When I run MakeMakefile with my path set up to use automake-1.8, I get
an error because MakeMakefile explicitly calls "automake-1.7' in two
places rather then just calling "automake".  Is this a subtle way of
telling me that my 1.8 automake is too new?

This explicit call to automake-1.7 is different from the example given in


which deals with similar issues of undefined macros.  In any case, I
downloaded/built automake 1.7.9 and got past this problem.

Next I appear to be missing ltmain.sh in the top level
directory. Copied the version in config/ to the top level. Then
running MakeMakefile reports:

  libtool --version = 1.4.3  (expected 1.4.2)
  automake-1.7 --version = 1.7.9  (expected 1.7)
  autoconf --version = 2.59  (expected 2.54)
  + find . -name Makefile
  + xargs rm -f
  + find . -name '*.la'
  + xargs rm -f
  + find . -name Makefile.in
  + xargs rm -f
  + libtoolize --copy --force
  You should update your `aclocal.m4' by running aclocal.
  Putting files in AC_CONFIG_AUX_DIR, `config'.
         [note, running aclocal in the directory doesn't clear this
  + cp ltmain.sh config
  + aclocal
  + autoheader --warnings=all
  autoheader: error: AC_CONFIG_HEADERS not found in configure.ac
  + automake-1.7 --foreign --add-missing --force-missing --copy
  libraries/cgilib-0.4/Makefile.am:1: Libtool library used but `LIBTOOL'
  is undefined
  libraries/cgilib-0.4/Makefile.am:1: The usual way to define `LIBTOOL'
  is to add `AC_PROG_LIBTOOL'
  libraries/cgilib-0.4/Makefile.am:1: to `configure.ac' and run
  `aclocal' and `autoconf' again.
  libraries/freetype-2.0.5/Makefile.am:6: Libtool library used but
  `LIBTOOL' is undefined
    ...      [ more instances of this error sequence removed]
  + autoconf
  configure.ac:228: error: possibly undefined macro: AC_DISABLE_SHARED
        If this token and others are legitimate, please use m4_pattern_allow.
        See the Autoconf documentation.
  configure.ac:229: error: possibly undefined macro: AC_PROG_LIBTOOL

Does anybody have a pointer to tricks/procedure to build the cvs 1.1.x
tree of rrdtool? I tried googling, but either got too many hits or the
30 or so hits I did get were for version 1.0.x of rrdtool.

Does anybody have any other ideas for what is happening here. Did I
just get a broken snapshot?

				-- rouilj
John Rouillard
My employers don't acknowledge my existence much less my opinions.

Unsubscribe mailto:rrd-developers-request at list.ee.ethz.ch?subject=unsubscribe
Help        mailto:rrd-developers-request at list.ee.ethz.ch?subject=help
Archive     http://www.ee.ethz.ch/~slist/rrd-developers
WebAdmin    http://www.ee.ethz.ch/~slist/lsg2.cgi

More information about the rrd-developers mailing list