[rrd-developers] [PATCH] add 'flush' to language bindings

Tobias Oetiker tobi at oetiker.ch
Sat Mar 7 11:33:50 CET 2009

Hi Kevin,

Yesterday kevin brintnall wrote:

> Tobi,
> This 2-patch series exposes 'flush' methods to the various language
> bindings.

the bindings look ok to me, I have applied the patch

> I noticed that most of the other API-visible functions are "rrd_X", but
> flush is "rrd_cmd_flush".  Should we rename to "rrd_flush" to match the
> others? The only problem I can see is potential confusion with
> "rrdc_flush".  Maybe we should rename both?

well I think calling it rrd_flush would be nice since it is
consistant with the rest of the rrd_* calls and that is a good


> Patches to follow...
> _______________________________________________
> rrd-developers mailing list
> rrd-developers at lists.oetiker.ch
> https://lists.oetiker.ch/cgi-bin/listinfo/rrd-developers

Tobi Oetiker, OETIKER+PARTNER AG, Aarweg 15 CH-4600 Olten, Switzerland
http://it.oetiker.ch tobi at oetiker.ch ++41 62 775 9902 / sb: -9900

More information about the rrd-developers mailing list