[rrd-developers] [PATCH] add 'flush' to language bindings

kevin brintnall kbrint at rufus.net
Fri Mar 20 20:29:44 CET 2009

On Sat, Mar 07, 2009 at 11:33:50AM +0100, Tobias Oetiker wrote:
> > I noticed that most of the other API-visible functions are "rrd_X", but
> > flush is "rrd_cmd_flush".  Should we rename to "rrd_flush" to match the
> > others? The only problem I can see is potential confusion with
> > "rrdc_flush".  Maybe we should rename both?
> well I think calling it rrd_flush would be nice since it is
> consistant with the rest of the rrd_* calls and that is a good
> thing.

It looks like that conflicts with this (internal) function in rrd_open:

	/* flush all data pending to be written to FD.  */
	void rrd_flush(
	    rrd_file_t *rrd_file)
	{ calls fdatasync() on it }

It looks like it's only referenced from rrd_hw.c..  is it really necessary
to enforce flush to disk at in the holt-winters processing?  That might
explain why HW processing is so much more IO intensive?

 kevin brintnall =~ /kbrint at rufus.net/

More information about the rrd-developers mailing list