[rrd-developers] [PATCH] add 'flush' to language bindings

Sebastian Harl sh at tokkee.org
Fri Mar 27 11:21:14 CET 2009


On Fri, Mar 20, 2009 at 02:29:44PM -0500, kevin brintnall wrote:
> On Sat, Mar 07, 2009 at 11:33:50AM +0100, Tobias Oetiker wrote:
> > > I noticed that most of the other API-visible functions are "rrd_X", but
> > > flush is "rrd_cmd_flush".  Should we rename to "rrd_flush" to match the
> > > others? The only problem I can see is potential confusion with
> > > "rrdc_flush".  Maybe we should rename both?
> > 
> > well I think calling it rrd_flush would be nice since it is
> > consistant with the rest of the rrd_* calls and that is a good
> > thing.
> It looks like that conflicts with this (internal) function in rrd_open:
> It looks like it's only referenced from rrd_hw.c..  is it really necessary
> to enforce flush to disk at in the holt-winters processing?  That might
> explain why HW processing is so much more IO intensive?

I've noticed that, in revisions 1760 and 1761, Tobi removed that symbol
entirely. However, this is a backward incompatible change to the API and
ABI and thus requires a bump of the major soname version. Since that
happened in 1.3.0 already, frankly, this is a rather bad idea,
particularly, as people are thinking about a more in-depth redesign of
the API (see the discussion last summer).

Since rrd_cmd_flush() has not yet been released, we can safely change
that though. However, I'm not sure about a good choice for a new name.
Since that command is rrdcached specific, a less generic name would be
fine imho. For consistency, we should also think about renaming
rrdflush(1) to match the new name as well.

What do you think about that? Any comments or suggestions?


Sebastian "tokkee" Harl +++ GnuPG-ID: 0x8501C7FC +++ http://tokkee.org/

Those who would give up Essential Liberty to purchase a little Temporary
Safety, deserve neither Liberty nor Safety.         -- Benjamin Franklin

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: Digital signature
Url : http://lists.oetiker.ch/pipermail/rrd-developers/attachments/20090327/99798541/attachment-0001.bin 

More information about the rrd-developers mailing list