[rrd-developers] [PATCH] add 'flush' to language bindings
rrdtool at nospam.verplant.org
Fri Mar 27 22:03:28 CET 2009
On Fri, Mar 27, 2009 at 03:29:07PM +0100, Tobias Oetiker wrote:
> > Most of them are already rrdc_*. I don't see a reason to s/^rrdc/rrdcd/.
> sure, rrdc_* is fine too
I used the `rrdc_' prefix for all exported functions which connect to
the server. The `c' was meant as apprevation for `client'.
I have to admit I don't quite see the need for introducing a different
prefix. What problem is that supposed to solve?
As for `rrd_cmd_flush': I used that name, because there already was a
function called `rrd_flush' that was exported. Dropping that old
function and changing the new function's name is, in my opinion, not a
good move and will create problems.
Florian octo Forster
Hacker in training
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Size: 189 bytes
Desc: Digital signature
Url : http://lists.oetiker.ch/pipermail/rrd-developers/attachments/20090327/16732b0f/attachment.bin
More information about the rrd-developers