[rrd-developers] [PATCH] add 'flush' to language bindings
tobi at oetiker.ch
Sat Mar 28 12:15:02 CET 2009
Yesterday Florian Forster wrote:
> On Fri, Mar 27, 2009 at 03:29:07PM +0100, Tobias Oetiker wrote:
> > > Most of them are already rrdc_*. I don't see a reason to s/^rrdc/rrdcd/.
> > sure, rrdc_* is fine too
> I used the `rrdc_' prefix for all exported functions which connect to
> the server. The `c' was meant as apprevation for `client'.
> I have to admit I don't quite see the need for introducing a different
> prefix. What problem is that supposed to solve?
> As for `rrd_cmd_flush': I used that name, because there already was a
> function called `rrd_flush' that was exported. Dropping that old
> function and changing the new function's name is, in my opinion, not a
> good move and will create problems.
yes dropping rrd_flush from the api is not a good idea, otoh it
does not acomplish anything sensible in the code, so I propose the
have rrdc_flush for the client flushing function
and turn rrd_flush into a no-op for backward compatibility
Tobi Oetiker, OETIKER+PARTNER AG, Aarweg 15 CH-4600 Olten, Switzerland
http://it.oetiker.ch tobi at oetiker.ch ++41 62 775 9902 / sb: -9900
More information about the rrd-developers