[rrd-developers] How do I install RRDs 1.4.1 in a shared hosted environment (no admin rights)

AllSort ofQuestions allsortofquestions at yahoo.com
Mon Jan 11 12:54:24 CET 2010

I am posting again, apparently the initial message didn't reach the list, I have no idea why. Please excuse me if this is going to result in duplicate messages

Hi all

For what I have done so far in this respect please see also http://www.mail-archive.com/rrd-users@lists.oetiker.ch/msg16146.html. Some excerpts are included below
Basically I managed to have perl-rrdtool (create and graph)  working for version 1.0.x but I cant make it work for the newest versions. I really need options like no-boorder
and -slope-mode. 

Can anybody please help me with this? I believe a regular user would have no idea about how to trick perl and the shared librarise (.so) loader
to look for what they need somewhere in $HOME instead of looking for them where all the other modules and shared libraries are and this is 
why I am asking here and not in rrd-users. Please excuse me again if this is wrong

Any other alternative to generate images using the latest graph options will be OK please feel free to suggest any.
BTW, can I collect data with an older version or RRDs and create graphs with a newer version of rrdcgi/rrdtool/rrds ? 

So far I have tried to configure the following (all failed):

1]   rrdcgi  -configuring this one requires access to the Apache .conf files. I added the following lines to .htaccess in order to determine the server to process the .rrdcgi files via rrdcgi executable. The path was aslo added to the shebang line.

<Directory /var/chroot/home/content/username/html/cgi>
    AddHandler cgi-script .rrdcgi

2]  rrdtool (the binary) but this one is asking for some libraries too, some rrdtool.so that it can't find (see  http://www.mail-archive.com/rrd-users@lists.oetiker.ch/msg16146.html)

I also tried /lib/ld-linux.so.2 --library-path PATH EXECUTABLE
This somehow change something but I don't know enough about Unix to say what 
exactly changed. Please see below

[u... at p3nlh047 bin]$ ./rrdtool
./rrdtool: error while loading shared libraries: librrd.so.4: cannot open 
shared object file: No such file or directory


[u... at p3nlh047 bin]$ /lib/ld-linux.so.2 --library-path . rrdtools
rrdtools: error while loading shared libraries: rrdtools: cannot open shared 
object file
[cris... at p3nlh047 bin]$
3] perl RRDs.pm - which generates this error when reffered with "use lib" in the perl script that should generate my image
for module RRDs: librrd.so.2: cannot open shared object file: No such file or
directory at /usr/lib/perl5/5.8.8/i386-linux-thread-multi/DynaLoader.pm line at script.pl line 3

Yahoo!  Canada Toolbar :Search from anywhere on  the web and bookmark your favourite sites. Download it now!  

The new Internet Explorer® 8 - Faster, safer, easier.  Optimized for Yahoo!  Get it Now for Free! at http://downloads.yahoo.com/ca/internetexplorer/
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.oetiker.ch/pipermail/rrd-developers/attachments/20100111/d0e97790/attachment-0001.htm 

More information about the rrd-developers mailing list