[rrd-users] Re: rrdtool 1.0.6 core dumps on FreeBSD 3.2 during graph

Jesper Skriver jesper at skriver.dk
Thu Aug 19 19:18:39 MEST 1999

On Thu, Aug 19, 1999 at 06:22:45PM +0200, Alex van den Bogaerdt wrote:
> > But on 1.0.6 i get a core dump "Memory fault (core dumped)"
> > 
> > This is on FreeBSD 3.2-STABLE (3.2-RELEASE can also be used) ...
> > 
> > Any ideas ?
> > 
> > The rrd in question is at http://e.t.dk/aaanxt1.ip.tele.dk.atm6-0.84.rrd
> > 
> I tried to do this on RedHat linux 6.0, and it works as expected:
> [alex at bigmac rrd]$ ./doit 
> 0x0
>              2272953
>               471507
>               983047
>               217615
> Perhaps you could use a debugger to find out where it dumps core?

I don't know if this helps anyone ?

$ gdb /usr/local/rrdtool-1.0.6/bin/rrdtool rrdtool.core 
GNU gdb 4.18
Copyright 1998 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-unknown-freebsd"...
Core was generated by `rrdtool'.
Program terminated with signal 10, Bus error.
Reading symbols from /usr/lib/libm.so.2...done.
Reading symbols from /usr/lib/libc.so.3...done.
Reading symbols from /usr/libexec/ld-elf.so.1...done.
#0  0x2810a843 in bcopy () from /usr/lib/libc.so.3
(gdb) bt
#0  0x2810a843 in bcopy () from /usr/lib/libc.so.3
#1  0x28117b50 in .curbrk () from /usr/lib/libc.so.3
#2  0x2810abaf in bcopy () from /usr/lib/libc.so.3
#3  0x2810add9 in bcopy () from /usr/lib/libc.so.3
#4  0x2810cc47 in __dtoa () from /usr/lib/libc.so.3
#5  0x2810a0f5 in vfprintf () from /usr/lib/libc.so.3
#6  0x281082d6 in vfprintf () from /usr/lib/libc.so.3
#7  0x280fac72 in sprintf () from /usr/lib/libc.so.3
#8  0x804e6cb in print_calc (im=0xbfbfaf28, prdata=0xbfbfb3dc)
    at rrd_graph.c:1440
#9  0x8050375 in graph_paint (im=0xbfbfaf28, calcpr=0xbfbfb3dc)
    at rrd_graph.c:2160
#10 0x805204b in rrd_graph (argc=12, argv=0xbfbfdbb8, prdata=0xbfbfb3dc,
    xsize=0xbfbfb3d8, ysize=0xbfbfb3d4) at rrd_graph.c:2926
#11 0x8049714 in HandleInputLine (argc=13, argv=0xbfbfdbb4, out=0x80833a0)
    at rrd_tool.c:222
#12 0x80493b6 in main (argc=13, argv=0xbfbfdbb4) at rrd_tool.c:158
#13 0x8049175 in _start ()

> Have you tried to use a smaller filename ? (to narrow it down)

Yes, but then I don't see the problem, actually I have thousands of rrd
files, and it only happends on some 5-10 % of them ... strange ...


Jesper Skriver (JS4261-RIPE), Network manager      
Tele Danmark DataNet, IP section (AS3292)

One Unix to rule them all, One Resolver to find them,
One IP to bring them all and in the zone to bind them.

* To unsubscribe from the rrd-users mailing list, send a message with the
  subject: unsubscribe to rrd-users-request at list.ee.ethz.ch

More information about the rrd-users mailing list