[rrd-users] RRDtool for dummies

eddie eddie at maxis.net.my
Mon Jul 24 08:59:33 MEST 2000

Are there any reference for non-programmer.  I have no problem with MRTG to
get any counters I want as long as it support SNMP.  However, when I tried
on RRDtool am totally lost.  I've tried many times but no success.  I know
RRDTools is the only software that can provide multiple counters in single
graph whereas MRTG can only have two.  Anyway, this is how I create the

I think the problem is on

1.  Create the rrd file
./rrdtool create pop1conx.rrd    \
        DS:pop1conx:COUNTER:600:U:U     \
        RRA:AVERAGE:0:5:1:600   \
        RRA:AVERAGE:0:5:6:600   \
        RRA:AVERAGE:0:5:24:700  \
        RRA:AVERAGE:0:5:288:797 \
        RRA:MAX:0.5:1:600       \
        RRA:MAX:0.5:6:700       \
        RRA:MAX:0.5:24:775      \

2.  Script to get the counter.  I got stucked here.

$pop1conx = `snmpget dingo .`;
@cmd="/usr/local/rrdtool-1.0.24/bin/rrdtool update webconx.rrd N:$pop1conx";

The script returns with the following error:

RROR: expected 1 data source readings (got 0) from =:...

I think the snmpget doesn't get the single result.  If I use snmpget to the
server, I got this result instead of the value 12:

[root at eddx bin]# snmpget dingo .
enterprises.311. = 12

3.  Due to the above error, my below graph appears to be counterless.

Would appreciate help.


Unsubscribe mailto:rrd-users-request at list.ee.ethz.ch?subject=unsubscribe
Help        mailto:rrd-users-request at list.ee.ethz.ch?subject=help
Archive     http://www.ee.ethz.ch/~slist/rrd-users
WebAdmin    http://www.ee.ethz.ch/~slist/lsg2.cgi

More information about the rrd-users mailing list