[rrd-users] RRDs problem with -c/--color tag

Chris Cho ccho at ucla.edu
Thu Jul 5 21:53:43 MEST 2001

Hi all, I'm new to the list, but have been using RRDtool for about 6 months now. I try to do all the RRDtool stuff withing RRDs, and here is where I am running into the problem. My system is running Debian Woody, RRDs version 1.0.33-1.

#! /usr/bin/perl
use RRDs;

($averages, $xsize, $ysize) = RRDs::graph (
  "-s $start_time",
  "-e $end_time",
  "-t $title",
  "-c CANVAS\#FF0000",        #### This is where I have all my problems, if I comment this line out, everything works fine
  "-v $vertical_label",
  "-w $width",
  "-h $height",
  "-l $lower_limit",
#### END OF CODE ####
OK, so I left alot of the variable values out, but thats really not the issue. Now, when I try the -c tag to change the color of the CANVAS, or any other color tag, I get this error:
invalid color def format
Ok, so I stuck a \# in there instead of just straight #, cuz its perl and I don't want a comment there :) Also, escaping # works later in the AREA color, so I don't see why that wouldn't work. I've tried it both ways, then I've also tried settaing a $color = 'CANVAS#FF0000' variable and using $color instead of hand writing the -c in, that also doesn't work. Now, I've also tried using the --color tag, but that gives me this error:
uknown option: '--color CANVAS#FF0000'
Is -c/--color supported in RRDs? Any help would be greatly appreciated, thanks for all your time.

Unsubscribe mailto:rrd-users-request at list.ee.ethz.ch?subject=unsubscribe
Help        mailto:rrd-users-request at list.ee.ethz.ch?subject=help
Archive     http://www.ee.ethz.ch/~slist/rrd-users
WebAdmin    http://www.ee.ethz.ch/~slist/lsg2.cgi

More information about the rrd-users mailing list