[rrd-users] killspike and rrdtool restore error

Peter Kassies p.kassies at ptt-post.nl
Wed Nov 14 15:41:03 MET 2001


I have some graphs with spikes.
I do a dump of the rrd archive as mentioned in the document:
rrdtool dump /disk1/test/venus/venus.hme1.rrd >in.xml

I run ./killspike. I get an error.

This due to the fact that some records have a different time setting. Some
rows are like:
<!-- 2001-10-28 03:00:00 MET / 1004234400 --> <row><v> 3.1025566602e
+03 </v><v> 2.0847081921e+04 </v></row>

And other are like
<!-- 2001-10-28 02:00:00 MET DST / 1004227200 --> <row><v> 6.8959697
549e+03 </v><v> 3.7765751605e+04 </v></row>
This probably has to do with the summer/wintertime settings of Solaris.
I vi the in.xml and remove (:g/DST /s//) all the DST entries.

I run killspike again, it finds quite a few spikes. Great.

Then I import the data again.
rrdtool restore out.xml /disk1/test/venus/venus.hme1.rrd

I get an error: ERROR: No </database> tag found.
Hmm, cat out.xml | grep '<database>' | wc -l gives 12.
cat out.xml | grep '<database>' | wc -l gives 12 too.

If I do a "diff in.xml out.xml" it shows me the 25 lines that have been
So what am I doing wrong?

Any help is greatly appreciated.

Peter Kassies

Unsubscribe mailto:rrd-users-request at list.ee.ethz.ch?subject=unsubscribe
Help        mailto:rrd-users-request at list.ee.ethz.ch?subject=help
Archive     http://www.ee.ethz.ch/~slist/rrd-users
WebAdmin    http://www.ee.ethz.ch/~slist/lsg2.cgi

More information about the rrd-users mailing list