[rrd-users] RRDtool update not updating

David Ulevitch davidu at everydns.net
Thu Jan 17 09:14:33 MET 2002

Hello rrd-users,

  I am trying to setup RRDtool to monitor certain packet counts for
  IPtables.  I wrote a small perl script which outputs this sort of
  line that then gets executed:

> [root at everydns brick]# ./traffic.pl
> /usr/local/rrdtool-1.0.33/bin/rrdtool update ns1.rrd N:682255:1695194
> /usr/local/rrdtool-1.0.33/bin/rrdtool update ns2.rrd N:503879:1316280
> /usr/local/rrdtool-1.0.33/bin/rrdtool update ns3.rrd N:48262:14435

That information is all correct.  The problem is that I ran it
once from the command line, creating an entry but from then on, I
couldn't add entries.  I set cron to run it every 5 minutes and it has
no entries and I only see my lone entry when I run:

> /usr/local/rrdtool-1.0.33/bin/rrdtool fetch ns1.rrd AVERAGE -s `date +%s`-14400 -e `date +%s`

How come I can't insert viz cron or command line after that one time?
 Does it have to do with the fact that now the timing is off?  How can
I fix this.

Thank you in advance.

 David Ulevitch                       mailto:davidu at everydns.net
 Founder, EveryDNS.net                http://www.everydns.net     

Unsubscribe mailto:rrd-users-request at list.ee.ethz.ch?subject=unsubscribe
Help        mailto:rrd-users-request at list.ee.ethz.ch?subject=help
Archive     http://www.ee.ethz.ch/~slist/rrd-users
WebAdmin    http://www.ee.ethz.ch/~slist/lsg2.cgi

More information about the rrd-users mailing list