[rrd-users] Re: RRDtool update not updating

Alex van den Bogaerdt alex at slot.hollandcasino.nl
Thu Jan 17 11:25:24 MET 2002

David Ulevitch wrote:

> That information is all correct.  The problem is that I ran it
> once from the command line, creating an entry but from then on, I
> couldn't add entries.  I set cron to run it every 5 minutes and it has
> no entries and I only see my lone entry when I run:
> > /usr/local/rrdtool-1.0.33/bin/rrdtool fetch ns1.rrd AVERAGE -s `date +%s`-14400 -e `date +%s`

Two possible problems:

1: when run from cron, the program is executed in another directory
   and thus the .rrd file cannot be found
2: the PATH environment variable is not setup and thus the "date"
   program cannot be found

 / alex at slot.hollandcasino.nl                  alex at ergens.op.het.net \
| work                                                         private |
| My employer is capable of speaking therefore I speak only for myself |
| Technical questions sent directly to me will be nuked. Use the list. | 
| http://faq.mrtg.org/                                                 |
| http://rrdtool.eu.org  --> tutorial                                  |

Unsubscribe mailto:rrd-users-request at list.ee.ethz.ch?subject=unsubscribe
Help        mailto:rrd-users-request at list.ee.ethz.ch?subject=help
Archive     http://www.ee.ethz.ch/~slist/rrd-users
WebAdmin    http://www.ee.ethz.ch/~slist/lsg2.cgi

More information about the rrd-users mailing list