[rrd-users] Re: Solaris 8 Compile Errors

Abid Khwaja abid at tyrann.net
Sun Jul 14 18:38:51 MEST 2002

On 7/13/02 8:24 PM, "Alex van den Bogaerdt" <alex at ergens.op.HET.NET> wrote:

> Abid Khwaja wrote:
> Note: I'm not a solaris user.  Bare with me if this is gibberish.
>> I¹ve searched the archives but couldn¹t find anything specific to my
>> problem.  I¹ve got all the GNU packages installed and am running Perl 5.6.1.
>> All GNU packages and Perl were precompiled versions.  Configure completes
>> successfully but make generates the following errors:
>> /usr/ccs/bin/as: "/var/tmp/ccVBGjU5.s", line 1654: error: unknown opcode
>> ".subsection"
> "/usr/ccs/bin/as".  Is this the GNU version?  Try /usr/ccs/bin/as --help

No, it's the Sun Workshop version.  Since I don't have a Sun compiler, I
installed a precompiled gcc - this didn't come with its own as.

>> SMCgcc301       gcc
>>                  (sparc) 3.0.1
> Not sure but I think this should include another copy of "as".
>> PATH=/usr/symcli/bin:/bin:/usr/bin:/usr/sbin:/usr/local/bin:/opt/SUNWspro/
>> bin:/usr/ucb:/etc:/usr/openwin/bin:/opt/SUNWmd/sbin:/usr/opt/WIZCOM/bin:/sbi
>> n/nsr:/usr/bin/nsr:/opt/VRTSvxva/bin:/opt/VRTSvmsa/bin:/etc/vx/bin:/usr/lib/
>> fs/vxfs:/opt/VRTSvcs/bin:/usr/ccs/bin:/opt/RICHPse/bin:.
> You wrote that the installed packages are in /usr/local.  Maybe there's
> a symlink inside /usr/symcli/bin, /bin, /usr/bin or /usr/sbin pointing
> to /usr/ccs/bin/as ?
> Also check the generated makefiles, override the location of AS etc.

I checked the entire machine; there's only 1 copy of as and it's in

Interestingly, I have another machine on which I tried to compile and it
worked fine on that one even though that machine also only has a single copy
of as in /usr/ccs/bin.  There are many differences between the two machines
to trying to pinpoint why the compile works on one but not the other is
proving difficult.

Unsubscribe mailto:rrd-users-request at list.ee.ethz.ch?subject=unsubscribe
Help        mailto:rrd-users-request at list.ee.ethz.ch?subject=help
Archive     http://www.ee.ethz.ch/~slist/rrd-users
WebAdmin    http://www.ee.ethz.ch/~slist/lsg2.cgi

More information about the rrd-users mailing list