[rrd-users] dump/restore appears broken

Dulac, Daniel (Dan) ddulac at aprisma.com
Tue Aug 5 21:21:29 MEST 2003


Hi Everyone,

I have been trying to solve a problem that I thought was a bug in my script
but it appears to be a problem with the dump and/or restore command with
rrdtool on Windows.

Test this:

1. With an existing *.rrd, run the "dump" command:
	rrdtool dump test.rrd >xml_orig.xml

2. Restore to a new rrd using the "restore" command:
	rrdtool restore test_restore.rrd xml_orig.xml

3. Now run the "dump" command on this new rrd:
	rrdtool dump test_restore.rrd >xml_new.xml

The two xml files (xml_orig.xml and xml_new.xml) should be identical in file
size and data contained within but they are not.  The data in the
xml_new.xml file is all messed up and corrupted!  Has anyone else seen this?
I am currently running 1.0.40.  We also tried 1.0.45 and it still doesn't

Is it safe to assume this a legitimate bug with rrdtool?  Thanks for any


Unsubscribe mailto:rrd-users-request at list.ee.ethz.ch?subject=unsubscribe
Help        mailto:rrd-users-request at list.ee.ethz.ch?subject=help
Archive     http://www.ee.ethz.ch/~slist/rrd-users
WebAdmin    http://www.ee.ethz.ch/~slist/lsg2.cgi

More information about the rrd-users mailing list