[rrd-users] bug in rrdtool??

Oline Case ocase at directoresource.com
Fri Nov 14 23:07:25 MET 2003

When I update my rrd and then fetch the values, there is one value in my 
data file that does not match the rrd fetched value. The value comes up 
as NaN.

For example, here is what I run to create the rrd:
/usr/local/rrdtool-1.0.37/bin/rrdtool create binds.rrd --start 
1067756400 --step 3600 DS:bind:GAUGE:7200:0:U RRA:AVERAGE:0.99:1:168

(btw - I have tried the CF of  LAST and MAX with the same results)

Here is my data file that I use to update the rrd:
1068314400:13 1068318000:12 1068321600:12 1068325200:12 1068328800:12 
1068332400:12 1068336000:12 1068339600:12 1068343200:12 1068346800:12 
1068350400:12 1068354000:12 1068357600:12

When I fetch, using this command:
/usr/local/rrdtool-1.0.37/bin/rrdtool fetch binds.rrd AVERAGE --start 
1067756400 --end 1068357600

I get these values where the epoch time of 1068314400 is NaN for the 
fetch output but in my data file the value is 13.
1068310800: NaN
1068314400: NaN
1068318000: 1.2000000000e+01
1068321600: 1.2000000000e+01
1068325200: 1.2000000000e+01
1068328800: 1.2000000000e+01
1068332400: 1.2000000000e+01
1068336000: 1.2000000000e+01
1068339600: 1.2000000000e+01
1068343200: 1.2000000000e+01
1068346800: 1.2000000000e+01
1068350400: 1.2000000000e+01
1068354000: 1.2000000000e+01
1068357600: 1.2000000000e+01

Is there something I am doing wrong to create this NaN value rather than 
the actual value of 13? Or is this a bug?


-- Attached file removed by Ecartis and put at URL below --
-- Type: application/x-pkcs7-signature
-- Desc: S/MIME Cryptographic Signature
-- Size: 3k (3202 bytes)
-- URL : http://www.ee.ethz.ch/~slist/p/79-smime.p7s

Unsubscribe mailto:rrd-users-request at list.ee.ethz.ch?subject=unsubscribe
Help        mailto:rrd-users-request at list.ee.ethz.ch?subject=help
Archive     http://www.ee.ethz.ch/~slist/rrd-users
WebAdmin    http://www.ee.ethz.ch/~slist/lsg2.cgi

More information about the rrd-users mailing list