[rrd-users] rrdtool 1.0.45 graph segfaults using -B/--background option

Josh Wyatt Josh.Wyatt at hcssystems.com
Mon Oct 13 21:13:55 MEST 2003

Hi All,

I'm using rrdtool 1.0.45.  I am trying the following command:
/opt/local/rrdtool/bin/rrdtool graph /tmp/be.gif -s 1032811200 -e 1032872400 -t  -i -a GIF --background /tmp/rstest2.gd 
--alt-autoscale -w 600 -h 200 -c BACK#101010 -c CANVAS#404040 -c FONT#ffffff -c MGRID#cfcfcf -c GRID#656535 
DEF:E0=/tmp/latency.rrd:latency:AVERAGE LINE2:E0#4e3fcd:'latency(milliseconds)' DEF:E1=/tmp/latency2.rrd:latency:AVERAGE 
LINE2:E1#1f9d2e:'latency2(milliseconds)' DEF:E2=/tmp/latency3.rrd:latency:AVERAGE LINE2:E2#cd4e3f:'latency3(milliseconds)'

And I get a segfault, no core dump.  Same thing happens when using perl shared RRDs::graph.

Any thoughts?

I used the pngtogd from GD-2.0.15 to generate rstest2.gd since no pngtogd is included with rrdtool.  I also tried 
pngtogd2, with the same result.


Unsubscribe mailto:rrd-users-request at list.ee.ethz.ch?subject=unsubscribe
Help        mailto:rrd-users-request at list.ee.ethz.ch?subject=help
Archive     http://www.ee.ethz.ch/~slist/rrd-users
WebAdmin    http://www.ee.ethz.ch/~slist/lsg2.cgi

More information about the rrd-users mailing list