[rrd-users] Re: Installing RRDtool

Jessie Shi jessie at freepeers.com
Thu Oct 23 00:24:52 MEST 2003

I am a new user of RRDTool, and got the problem as follows. Any help
will be appreciated. Thanks.
I am using MS Windows XP and Activeperl 5.6.1. I followed the following
1.       downloaded rrdtool-1.0.40.x86distr.zip-5.8.zip and unzip it to
2.       went in the perl-shared directory and type 
                        ppm install rrds.ppd
3.       Then got the following error message:
Installing package 'rrds.ppd'...
Error installing package 'rrds.ppd': Read a PPD for 'rrds.ppd', but it
is not intended for this build of Perl (MSWin32-x86-multi-thread)
  Which build of perl it is talking about? I noticed that in
README-X86-NT.txt it mentioned perl 5.6 should be using. Does Activeperl
5.6.1 not work for it? If Perl 5.6 is the must, where can I get it?
Thanks a lot!
*       Jessie
*	To: "'Rrdtool List (E-mail)'" <rrd-users at list.ee.ethz.ch> 
*	Subject: [rrd-users] Re: Installing RRDtool 
*	From: Glen Peake <glen{dot}
*	Date: Fri, 4 Jan 2002 08:43:25 +1100 
*	Cc: "'McClain, Dave'" <
Just wondering if anyone has a suggested fix for this, as I am also
experiencing the same error while trying to install 'rrds.ppm'.
The error is as follows:
"Error installing package 'rrds.ppd': Could not locate a PPD file for
package rrd
I'm running ActivePerl 5.61, same error on Windows NT 4.0 SP6a and
2000 SP2
I'm using 'rrdtool-1.0.33.tar.gz'..... in the package there is a file
'NT-BUILD-TIPS.txt' (see copy of text file below)
I'm going to try an older version of rrdtool to see if that works.
Compiling RRDtool on NT ... work in progress
by Tamas Kovacshazy (khazy{at}mit{dot}bme{dot}hu)
Persisting Problems with the current NT port:
Unfortunately, the RRD perl modules does not work with Perl (ActivePerl)
using the current distribution.
The RRD shared perl module can be compiled after some
Follow these steps:
0. Install perl if you do not have it!
Visit http://www.ActiveState.com/pw32/ for a complete distribution.
1.      Copy ..\gd1.2\release\gd.lib  to ..\gd1.2\
2.      Copy ..\src\release\rrd.lib to ..\src
3.      perl Makefile.pl
In this step the system complains about something I do not understand.
error message is the following:
Note (probably harmless): No library found for '-lm'
Is a library missing? But it does not stop with an error...
4.      nmake test (You must have Visual C++ on the machine!)
After these steps it generates the test files (gifs and rrds),
and they seem to be good.
The real problem in the shared perl modul is the following:
I do not know how this installation stuff works. The problem is that the
installation stuff looks for the gd.lib and the rrd.lib in the ..\gd1.2
..\src directory. The UNIX compile puts the files into these
but the NT compile does not.
It is all for today,
Tamas Kovacshazy  E-mail: khazy{at}mit{dot}bme{dot}hu  
WWW: http://www.mit.bme.hu/~khazy
Technical University of Budapest 
Department of Measurement and Information Systems
 -----Original Message-----
From:   McClain, Dave [mailto:dave{dot}mcclain{at}jacobsons{dot}com
<nospam:dave%7bdot%7dmcclain%7bat%7djacobsons%7bdot%7dcom> ] 
Sent:   Friday, 28 December 2001 08:52
To:     Rrdtool List (E-mail)
Subject:       [rrd-users] Installing RRDtool
I am a new RRDtool user, and I am having a problem with the ppm install
command.  I downloaded rrdtool-1.0.28.x86distr.zip, created a rrdtool
on my PC and unzipped the file to that folder.  I typed ppm install
from a command prompt.  
I am getting an error message saying Error installing package 'rrds.ppd'
Read of ./ failed.  Does anybody know what is causing this problem?
Thank you
Unsubscribe mailto:rrd-users-request at list.ee.ethz.ch?subject=unsubscribe
Help        mailto:rrd-users-request at list.ee.ethz.ch?subject=help
Archive     http://www.ee.ethz.ch/~slist/rrd-users
WebAdmin    http://www.ee.ethz.ch/~slist/lsg2.cgi

More information about the rrd-users mailing list