[rrd-users] Re: Can't install rrdtool(failed dependencies--perl(Net::SNMP) is needed by rrdtool-1.0.41-1.8.0)

Hugo van der Kooij hvdkooij at vanderkooij.org
Thu Oct 30 19:33:58 MET 2003

On Thu, 30 Oct 2003, [big5] milk layer wrote:

> I have downloaded rrdtool-1.0.41-1.8.0.i386.rpm and
> tried to install it by sudo rpm -ivh (file name). But
> an error message prompted: Failed dependencies: 
> perl(Net::SNMP) is needed by rrdtool-1.0.41-1.8.0.
> Then,I typed:
> $sudo perl -MCPAN -e shell
> $install Net::SNMP
> The last message stated that "Net::SNMP is up to
> date". But when i install the RPM again, it still
> failed with the same error message. Could anyone
> please suggest a solution to my problem?? And do i
> need to install any essential subpackages before the
> installation of rrdtool?

While the software is there, the packaging database is unaware of it. You 
must install all depencies through the package manager or override it.

I can recommend the cpan2rpm package to build your own Net::SNMP package 
or you can find a build package through rpmfind.net:


 All email sent to me is bound to the rules described on my homepage.
    hvdkooij at vanderkooij.org		http://hvdkooij.xs4all.nl/
	    Don't meddle in the affairs of sysadmins,
	    for they are subtle and quick to anger.

Unsubscribe mailto:rrd-users-request at list.ee.ethz.ch?subject=unsubscribe
Help        mailto:rrd-users-request at list.ee.ethz.ch?subject=help
Archive     http://www.ee.ethz.ch/~slist/rrd-users
WebAdmin    http://www.ee.ethz.ch/~slist/lsg2.cgi

More information about the rrd-users mailing list