[rrd-users] unpredictable step value in my output

ibb imq ibb_imq at yahoo.com
Fri May 28 17:29:22 MEST 2004

Hello all,
I am actually a newbie to rrdtool.I tried my hand on
it and it worked .But while creating the rrd file I
specified a step of 300 seconds but when i fetched to
see  how things went , i discovered that that the
difference betwwen the consecutive time values is
1,800 seconds.

Please, could somebody explain why this is so and what
to do to have a step of 300s. Thanks.

rrdtool create net10.rrd --step 300 \
--start 920804400                        
DS:nic:COUNTER:600:U:U \              
RRA:AVERAGE:0.5:1:24    \              
RRA:AVERAGE:0.5:6:10  \

The output of my fetch command is as below.
#rrdtool fetch net9.rrd AVERAGE
1085736600: nan
1085738400: nan
1085740200: 3.1000000000e-01
1085742000: 3.2101790329e+00
1085743800: 7.5709283869e+00
1085745600: 1.0687781469e+01
1085747400: 2.3855008628e+06
1085749200: 5.5055555556e-01
1085751000: 3.2111111111e-01
1085752800: 6.5388888889e-01
1085754600: nan

and my update and variable creation csript is this :

nic="`/sbin/ifconfig eth0 |grep frame|awk '{print
$2}'|sed -e 's/packets://'`"
echo "nic="`/sbin/ifconfig eth0 |grep frame|awk
'{print $2}'|sed -e 's/packets://'`""                 
#update rrd
/usr/bin/rrdtool update /home/ibro/net10.rrd N:$nic
echo "rrdtool /usr/bin/update /home/ibro/net10.rrd
# Gather information to print below the graph (legend)
graph_uptime="`uptime | sed -e "s/.*up //"`"
current_nic="`ifconfig eth0 | grep frame | awk '{print
$2}' | sed -e 's/packets://' `"
# Create  graph
/usr/bin/rrdtool graph nic10.gif --start 1085734800 -h
100 -w 200 -t "System Network Interface"


Do you Yahoo!?
Friends.  Fun. Try the all-new Yahoo! Messenger

Unsubscribe mailto:rrd-users-request at list.ee.ethz.ch?subject=unsubscribe
Help        mailto:rrd-users-request at list.ee.ethz.ch?subject=help
Archive     http://www.ee.ethz.ch/~slist/rrd-users
WebAdmin    http://www.ee.ethz.ch/~slist/lsg2.cgi

More information about the rrd-users mailing list