[rrd-users] How does timestamp work?

Giovane Moreira giovane at gmail.com
Thu Oct 7 20:57:32 MEST 2004

Guys, at least this is real weird...
Can somebody try to figure out this please?

I'm on GMT -3  time zone and all my graphs are outta phase.. I just
wanna they correct... -3h delayed...

I run these commans below and see what I got:

bash-2.05b$ rrdtool create data.rrd --start 1096599600  --step 86400 
DS:download:GAUGE:86400:0:U RRA:AVERAGE:0.5:1:400
RRA:AVERAGE:0.5:30:100 RRA:AVERAGE:0.5:365:2
bash-2.05b$ rrdtool fetch data.rrd AVERAGE --start 1096599600
timestamp    download

1096588800:  nan
1096675200:  nan
1096761600:  nan
1096848000:  nan
1096934400:  nan
1097020800:  nan
1097107200:  nan
1097193600:  nan

that is! the next update point is not  my start point plus step.
(1096599600 +86400 = 1096686000). The first point there is my start
point -10800 (-3hours delayed, due timezone, I suppose). RRDTOOL just
reduced my start point ... why?

So I tried to create other rrd files with differents start points.. by
adding 10800 and sub 10800 from 1096599600(midnight of 10/01/2004).
And I got the same update points...even I changing my start point, I
got the same update points.. sounds really weird...

Can someone help me please? In fact, I'm just trying to fix my
graphs..they're out of phase.. 3h delayed...

Thank you so much folks,

Giovane Moreira
Rede Nacional de Ensino e Pesquisa - Brasil

Unsubscribe mailto:rrd-users-request at list.ee.ethz.ch?subject=unsubscribe
Help        mailto:rrd-users-request at list.ee.ethz.ch?subject=help
Archive     http://www.ee.ethz.ch/~slist/rrd-users
WebAdmin    http://www.ee.ethz.ch/~slist/lsg2.cgi

More information about the rrd-users mailing list