[rrd-users] building the php4 module

Jakob Hirsch jh at plonk.de
Mon Apr 4 02:21:39 MEST 2005


this may have come up earlier, but I found no real solution on this list.
I wanted to use rrdtool.so without rebuilding apache/php/etc. Since I 
use Fedora (FC2), I tried the php-rrdtool rpm from dag, but got

PHP Warning:  Unknown(): Invalid library (maybe not a PHP library) 
'rrdtool.so'  in Unknown on line0

in my error_log. So I tried building it myself, but still getting the 
same message.
Searching aroung, I found a solution/workaround in 
Add #include "config.h" (I have no php_config.h) at the beginning of 
php_rrdtool.h. After ./configure and make I had a working module.

So I'm wondering, is this a flaw in the package or some oddity in my 
setup (though it seems others had the same problem).


Unsubscribe mailto:rrd-users-request at list.ee.ethz.ch?subject=unsubscribe
Help        mailto:rrd-users-request at list.ee.ethz.ch?subject=help
Archive     http://www.ee.ethz.ch/~slist/rrd-users
WebAdmin    http://www.ee.ethz.ch/~slist/lsg2.cgi

More information about the rrd-users mailing list