[rrd-users] Problems with install

Kern, Tom tkern at CHARMER.COM
Fri Jul 8 15:38:08 MEST 2005

I'm have a error thrown by configure everytime i run it for rrdtool-1.2.10
this is the error-

* I found a copy of pkgconfig, but there is no freetype2.pc file around.
  You may want to set the PKG_CONFIG_PATH variable to point to its

configure: WARNING:
* I could not find a working copy of freetype2. Check config.log for hints on why
  this is the case. Maybe you need to set LDFLAGS and CPPFLAGS appropriately
  so that compiler and the linker can find libfreetype and its header files. If
  you have not installed freetype2, you can get it either from its original home on


  You can find also find an archive copy on


  The last tested version of freetype2 is 2.1.9.

       LIBS=-lpng -lz -lm
  CPPFLAGS=-I/tmp/rrdbuild/lb/include -I/tmp/rrdbuild/lb/include/libart-2.0 -I/tmp/rrdbuild/lb/include/freetype2 -I/tmp/rrdbuild/lb/include/libpng -I/usr/include/freetype2

I followed the instructions here- http://people.ee.ethz.ch/~oetiker/webtools/rrdtool/doc/rrdbuild.en.html

I passed all the correct compiler and linker vars before make for both freetype2 and rrdtool and i still get that error.
is there anything else i can do?


-- Attached file removed by Ecartis and put at URL below --
-- Type: application/ms-tnef
-- Size: 2k (2622 bytes)
-- URL : http://lists.ee.ethz.ch/p/42CE84B215382-winmail.dat

Unsubscribe mailto:rrd-users-request at list.ee.ethz.ch?subject=unsubscribe
Help        mailto:rrd-users-request at list.ee.ethz.ch?subject=help
Archive     http://lists.ee.ethz.ch/rrd-users
WebAdmin    http://lists.ee.ethz.ch/lsg2.cgi

More information about the rrd-users mailing list