[rrd-users] Installing RRDTool 1.2.10 on Mac OS X (Panther)

Thomas Bretzke th.bretzke at taccon.com
Thu Jun 23 13:51:41 MEST 2005


I'm using rrdtool 1.0.49 for a long time now on my iBook G4 with Mac OS 
X 10.3.9 and I think it is the best software to graph logged data. Today 
I tried to compile and install RRDTool v1.2.10 on my Mac. Everything 
worked perfectly (all libraries have been installed succesfully) until I 
tried to MAKE the rrdtool itelf.
Make stops and tells me the following:

cc -dynamiclib -L/tmp/rrdbuild/lb/lib  -L../../src/.libs -L../../src 
-L/usr/local/rrdtool-1.2.10/lib tclrrd.o -o tclrrd1.2.10.dylib -lrrd -lm
ld: warning -L: directory name (/usr/local/rrdtool-1.2.10/lib) does not 
ld: Undefined symbols:
/usr/bin/libtool: internal link edit command failed
make[3]: *** [tclrrd1.2.10.dylib] Error 1
make[2]: *** [all-recursive] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2

What could be the problem? Can you help me? Thank you very much!

Thomas Bretzke.

Unsubscribe mailto:rrd-users-request at list.ee.ethz.ch?subject=unsubscribe
Help        mailto:rrd-users-request at list.ee.ethz.ch?subject=help
Archive     http://lists.ee.ethz.ch/rrd-users
WebAdmin    http://lists.ee.ethz.ch/lsg2.cgi

More information about the rrd-users mailing list