[rrd-users] Re: confusing errors

Natan nvivo at mandic.com.br
Fri May 20 19:13:16 MEST 2005

Alex van den Bogaerdt wrote:

>I tried to reproduce this and failed.
>What I did notice is this:  if you do something like:
>rrdtool graph DEF:ds0=test.rrd:ds0:AVERAGE VDEF:m=ds0,MAXIMUM PRINT:m:%lf
>then it produces an error:
>ERROR: Not a valid vname: ds0 in line VDEF:m=ds0,MAXIMUM
>It may not be clear that the "DEF" statement is actually the graph
>file name.
>Can you give an example line, as small as possible but one that still

...... I deleted the whole thing and started again, unfortunately i'm 
unable to reproduce the error now (duh)...
but i'll try it again at home to find the problem. Although I'm starting 
to think it was my mistake...
Now I'm stuck with this:

rrdtool graph image.png -s -1d --imgformat PNG 
DEF:in=sample.rrd:inOctets:AVERAGE CDEF:inBits=in,8,* 
VDEF:inMaxBits=inBits,MAXIMUM GPRINT:inMaxBits:%lf

always gives me:

ERROR: bad format for GPRINT in 'lf'

tried enclosing in double quotes, tried copying the example, tried ""...

any tip?


By the way, why doesn't this list has a "reply-to" field?

Unsubscribe mailto:rrd-users-request at list.ee.ethz.ch?subject=unsubscribe
Help        mailto:rrd-users-request at list.ee.ethz.ch?subject=help
Archive     http://lists.ee.ethz.ch/rrd-users
WebAdmin    http://lists.ee.ethz.ch/lsg2.cgi

More information about the rrd-users mailing list