[rrd-users] Compiling Problems

Kevin Gordon kevin.gordon at gmail.com
Sun Oct 23 22:06:16 MEST 2005

Im new to RRDTools and am having problems compiling this application
(Im a pretty big novice when it comes to compiling)

(Bash Shell)
I run ./configure

And I get

configure: WARNING:
* I could not find a working copy of cgilib. Check config.log for hints on
this is the case. Maybe you need to set LDFLAGS and CPPFLAGS appropriately
so that compiler and the linker can find libcgi and its header files. If
you have not installed cgilib, you can get it either from its original home


You can find also find an archive copy on


The last tested version of cgilib is 0.5.

LIBS=-lfreetype -lpng -lz -lm
CPPFLAGS= -I/usr/include/freetype2


configure: error: Please fix the library issues listed above and try again.

so then I do > LDFLAGS=/lib/ ./configure OR LDFLAGS=/lib; export LDFLAGS
( I have also tried $> LDFLAGS=/root/monitor\ tools/rrdtool-1.2.11/cgilib-
0.5/ ./configure )

I compiled CGILIB as a shared library and stuck it in the /lib/ folder

When I set the LDFLAGS=/lib/ or anything else I get the output (Starting
line 11)

checking whether make sets $(MAKE)... yes
checking for gcc... gcc
checking for C compiler default output file name... configure: error: C
compiler cannot create executables
See `config.log' for more details.

When I check the config log Im not sure what I am looking for

I was wondering if someone could point me in the right direction

Thanks in advance

Kevin Gordon

[Attached: config.log]

-- Attached file removed by Ecartis and put at URL below --
-- Type: application/octet-stream
-- Size: 8k (8463 bytes)
-- URL : http://lists.ee.ethz.ch/p/02-config.log

Unsubscribe mailto:rrd-users-request at list.ee.ethz.ch?subject=unsubscribe
Help        mailto:rrd-users-request at list.ee.ethz.ch?subject=help
Archive     http://lists.ee.ethz.ch/rrd-users
WebAdmin    http://lists.ee.ethz.ch/lsg2.cgi

More information about the rrd-users mailing list