[rrd-users] Re: Compiling Problems

D. Walsh info at daleenterprise.com
Mon Oct 24 02:40:43 MEST 2005

On Oct 23, 2005, at 16:06 , Kevin Gordon wrote:

> Im new to RRDTools and am having problems compiling this application
> (Im a pretty big novice when it comes to compiling)

It's not you, I went through the configure.ac file and noticed that  
none of the required libraries are import dynamically, that is to  
say, Tobi doesn't search for the location of the libraries and his  
strict use of pkg-config leaves a lot to be desired.

An alternative is to disable rrdcgi in the build process (--disable- 
rrdcgi) which you probably wont be using in most cases.

I can build the mainstream 1.2.6 with rrdcgi but 1.2.11 fails and  
1.2.11 doesn't like gcc 4.0.

I've reverted back to building the main stream rrdtool 1.2.6 which  
builds OK on Darwin and Mac OSX with a long configure line and then I  
modified his build code to actually search for the libraries and add  
them with path along with the required include directories and it  
seems to work much better this way (I mean, it builds with less user  
headaches and you don't have to specify all that LIB/LDFLAGS/CPPFLAGS  

I made a dist of the modified files, moved it to my gentoo box and it  
compiled there with no problems so all I can say is if you don't know  
enough to modify the building process then add the libs and paths to  
your configure statement.

Ex. (I built the required libraries in /usr/local so my command looks  
  ./configure --prefix=/usr/local/rrdtool --mandir=/usr/local/man  
LIBS="-lfreetype -lpng -lz -lm" LDFLAGS="-L/usr/local/lib"   

I could go on bashing the inconsistencies in his code but it makes  
little sense since they are mostly dismissed due to attitude and now  
I make a comment or two when something isn't working properly which  
also never seems to be resolved so while I am dependent on the  
software, I'll continue to use whatever version I can that provided  
the least amount of installation problems to achieve the intended goal

Example, a program written to make use of the librrd doesn't build  
properly because the rrd_graph function API has changed without  
providing any backwards compatibility and every prorgammer I've  
spoken too about this type of API changes consider this form of  
advancement to be a hack at best which forces other programmers who  
depend on rrdtool to be stuck with using a particular version of  
rrdtool because of the API incompatabilities.

Another example, the reported versions from RRDs.pm and RRDp.pm shows  
the version is 1.2006 which equates too 1.200.006 because the  
breakdown is decoded as "MAJOR_VER.MINOR_VER.REV_LEVEL", I think it  
should have been 1.002006 but why split hairs over something that's  
this trivial.

> (Bash Shell)
> I run ./configure
> And I get
> configure: WARNING:
> ---------------------------------------------------------------------- 
> ------
> * I could not find a working copy of cgilib. Check config.log for  
> hints on
> why
> this is the case. Maybe you need to set LDFLAGS and CPPFLAGS  
> appropriately
> so that compiler and the linker can find libcgi and its header  
> files. If
> you have not installed cgilib, you can get it either from its  
> original home
> on
> http://www.infodrom.org/projects/cgilib
> You can find also find an archive copy on
> http://people.ee.ethz.ch/~oetiker/webtools/rrdtool/pub/libs
> The last tested version of cgilib is 0.5.
> LIBS=-lfreetype -lpng -lz -lm
> CPPFLAGS= -I/usr/include/freetype2
> ---------------------------------------------------------------------- 
> ------
> configure: error: Please fix the library issues listed above and  
> try again.
> so then I do > LDFLAGS=/lib/ ./configure OR LDFLAGS=/lib; export  
> ( I have also tried $> LDFLAGS=/root/monitor\ tools/rrdtool-1.2.11/ 
> cgilib-
> 0.5/ ./configure )
> I compiled CGILIB as a shared library and stuck it in the /lib/ folder
> When I set the LDFLAGS=/lib/ or anything else I get the output  
> (Starting
> line 11)
> checking whether make sets $(MAKE)... yes
> checking for gcc... gcc
> checking for C compiler default output file name... configure:  
> error: C
> compiler cannot create executables
> See `config.log' for more details.
> When I check the config log Im not sure what I am looking for
> I was wondering if someone could point me in the right direction
> Thanks in advance
> Kevin Gordon
> [Attached: config.log]
> -- Attached file removed by Ecartis and put at URL below --
> -- Type: application/octet-stream
> -- Size: 8k (8463 bytes)
> -- URL : http://lists.ee.ethz.ch/p/02-config.log
> --
> Unsubscribe mailto:rrd-users-request at list.ee.ethz.ch? 
> subject=unsubscribe
> Help        mailto:rrd-users-request at list.ee.ethz.ch?subject=help
> Archive     http://lists.ee.ethz.ch/rrd-users
> WebAdmin    http://lists.ee.ethz.ch/lsg2.cgi

Unsubscribe mailto:rrd-users-request at list.ee.ethz.ch?subject=unsubscribe
Help        mailto:rrd-users-request at list.ee.ethz.ch?subject=help
Archive     http://lists.ee.ethz.ch/rrd-users
WebAdmin    http://lists.ee.ethz.ch/lsg2.cgi

More information about the rrd-users mailing list