[rrd-users] Re: Strange Error when running rrdtool.

Peter Valdemar Mørch swp5jhu02 at sneakemail.com
Fri Apr 14 02:27:07 MEST 2006

Tony Davis tony-at-ukcube.com |Lists| wrote:
> I have just rolled out a new linux server and install rrd for 
> monitoring, but i am getting this error when i run my rrdtool & rrdupdate.
> Error:
> rrdtool: /usr/lib/libpng12.so.0: no version information available 
> (required by /usr/local/rrdtool-1.2.12/lib/librrd.so.2)

When using VMWare, I've seen a similar warning. There it was because 
VMWare had installed its own libwhatever.so and my system already had a 
libwhatever.so . For that situation, simply removing VWmare's 
libwhatever.so fixed/removed the warning.

So, do you have a libpng12.so.0 installed in /usr/local/* ?
Do you have duplicates of any libpng12.so (or any .so libraries) on your 
system? If so, simply renaming/removing the non-standard on of them may 

For me, at least, that fixed it. So maybe this isn't "light", but maybe 
its "moonlight" and can point you in the right direction... :D

Peter Valdemar Mørch

Unsubscribe mailto:rrd-users-request at list.ee.ethz.ch?subject=unsubscribe
Help        mailto:rrd-users-request at list.ee.ethz.ch?subject=help
Archive     http://lists.ee.ethz.ch/rrd-users
WebAdmin    http://lists.ee.ethz.ch/lsg2.cgi

More information about the rrd-users mailing list