[rrd-users] rpmbuild issues

Abhijit Das Abhijit.Das at airwave.com
Tue Apr 18 02:52:29 MEST 2006


Recently I tried to build the RPM from rrdtool-1.2.12. However, I ran into
some problems regarding the build.

1)       %exclude %{_prefix}/shared/ under the first '%files' section gives
errors. It should probably be /share instead of shared.

2)       The '%doc rpm-doc/docs/ examples/' in the same section causes

3)       The font DejaVuSansMono-Roman.ttf is not copied over to the share
directory. And hence example files are unable to run.


When configured manually i.e. w/o using RPMs, it seems to work fine.


The following patch handles the equality case while drawing the graphs.


--- rrdtool-1.2.12/src/rrd_graph-orig.c 2006-04-17 14:46:55.166186709 -0700

+++ rrdtool-1.2.12/src/rrd_graph.c      2006-04-17 14:47:06.256356891 -0700

@@ -1582,7 +1582,7 @@

        else {

            for(i=0;ylab[i].grid > 0;i++){

                pixel = im->ysize / (scaledrange / ylab[i].grid);

-               if (pixel > 7) {

+               if (pixel >= 7) {

                    gridind = i;








Unsubscribe mailto:rrd-users-request at list.ee.ethz.ch?subject=unsubscribe
Help        mailto:rrd-users-request at list.ee.ethz.ch?subject=help
Archive     http://lists.ee.ethz.ch/rrd-users
WebAdmin    http://lists.ee.ethz.ch/lsg2.cgi

More information about the rrd-users mailing list