[rrd-users] Re: RRD error - min must be less than max in DS definition

Tobias Oetiker tobi at oetiker.ch
Wed Aug 9 14:33:08 MEST 2006

Hi Steffen,

Steffen.Pelzetter at nexans.com wrote:

> Here is the result:
> ./rrdtool create /tmp/tcp.orarns.tcp 'DS:sec:GAUGE:600:0:U'
> 'RRA:AVERAGE:0.5:1:576'

at least the current version of rrdtool does not exhibit this
behavior ...

> ERROR: min must be less than max in DS definition
> Next I've tried to re- compile and install rrd.
> If I try to ./configure I get an error- message:
> IEEE Math Checks
> checking for fpclassify... no
> checking for fpclassify with <math.h>... yes
> checking for finite... yes
> configure: error:
> Your Compiler does not do propper IEEE math ... Please find out how to
> make IEEE math work with your compiler and let me know (tobi at oetiker.ch).
> Check config.log to see what went wrong ...

have you had a look at the config.log file ? this should help you

if you are using solaris 10 then you may want to use the snapshot
version of rrdtool since I have worked around a bug where solaris
is only able to compile isinf if you use the forte compiler ...


Tobi Oetiker, OETIKER+PARTNER AG, Aarweg 15 CH-4600 Olten
http://tobi.oetiker.ch tobi at oetiker.ch ++41 62 213 9907

Unsubscribe mailto:rrd-users-request at list.ee.ethz.ch?subject=unsubscribe
Help        mailto:rrd-users-request at list.ee.ethz.ch?subject=help
Archive     http://lists.ee.ethz.ch/rrd-users
WebAdmin    http://lists.ee.ethz.ch/lsg2.cgi

More information about the rrd-users mailing list