[rrd-users] RRD step size retrieving older data

John Biederstedt john at johnsdomain.org
Thu Dec 21 19:48:41 MET 2006

I've notice the when I graph mrtg rrd data older than a few months, the
step size is always 24 hours.  For example, if I graph mrtg data
(gathered at 5 minute intervals) from 6 months ago, it's clearly graphed
in 24-hour step sizes:

rrdtool graph - \
--start='7/11/2006' \
--end='7/13/2006' \
--imgformat=PNG \
--width=1024 \
--base=1000 \
--height=256 \
--interlaced \
DEF:a=/var/www/mrtg/rtr-wan-mci//my_rtr_3.rrd:ds0:MAX:step=300 \
DEF:b=/var/www/mrtg/rtr-wan-mci//my_rtr_3.rrd:ds1:MAX:step=300 \
LINE1:a#008000:'Serial0/3/0 in' \
LINE1:b#0000FF:'Serial0/3/0 out'

Produces a graph that only shows changes at 7pm each day, even though I
forced the step in the DEF to 300 seconds.  I also tried the --step=300
leaving out the 'MAX:step=300' from the DEFs, with the same result. I
also tried with start and end times anywhere from an hour apart to a day
apart, and still there I couldn't get 300 second steps.  Is that just
how RRD works, or is there a way to get the 5-minute granularity from
older time periods?

Unsubscribe mailto:rrd-users-request at list.ee.ethz.ch?subject=unsubscribe
Help        mailto:rrd-users-request at list.ee.ethz.ch?subject=help
Archive     http://lists.ee.ethz.ch/rrd-users
WebAdmin    http://lists.ee.ethz.ch/lsg2.cgi

More information about the rrd-users mailing list