[rrd-users] RRDs.pm/RRDs.so errors

David Brodin brodin at durd.net
Mon Dec 31 13:26:37 CET 2007

Hi all!

Im new to the list, so be gentle :)

Anyway, im hacking my MyBook World Edition and am trying to set up MRTG with
RRDtool. But i cant get around this error, ive tried everything i can think
of except emailing this list (until now obv):

Can't load '/usr/local/rrdtool-1.2.26/lib/perl/5.8.8/armv5tejl-linux//auto/RRDs/RRDs.so'
for module RRDs: File not found at
/usr/local/lib/perl5/5.8.8/armv5tejl-linux/DynaLoader.pm line 230.
 at /usr/local/mrtg-2/bin/mrtg line 342
Compilation failed in require at /usr/local/mrtg-2/bin/mrtg line 342.

As you can see im running rrdtool 1.2.26, but ive tried running 1.2.25,
1.3b3 (cairo failed to compile for a reason that i couldnt fix), i did add
the PathAdd and LibAdd, MRTG is the latest, cfgmaker made the cfg, i tried
compiling without perl so to use the already installed one but it failed
more, chmoding RRDs.*, editing the bin mrtg and RRDs.pm itselves (ive
restored them).
Thats all i think... Google doesnt reveal much of any use.

So, any thoughts about whats causing this?
Is there anymore information i could give? (please, give a command too, im
moderately experienced at Linux id say, but still...).

Id really like to use rrdtool with mrtg, for the performance benefit as the
MyBook is running an ARM9 chipped processor at 200Mhz and doing anything
usually peaks it :) (more info about it here -
http://www.arm.com/products/CPUs/ARM926EJ-S.html )

Happy New Years from Sweden,

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.oetiker.ch/pipermail/rrd-users/attachments/20071231/4feaa821/attachment.html 

More information about the rrd-users mailing list