[rrd-users] VDEF hangs rrdtool

Alex van den Bogaerdt alex at ergens.op.het.net
Tue Jun 26 15:38:31 CEST 2007

On Tue, Jun 26, 2007 at 02:49:48PM +0200, Dag Erlandsson wrote:

> rrdtool graph - DEF:countA=/var/owdata/temp1.rrd:temp:AVERAGE
> VDEF:powerA=countA,TOTAL
> This command never returns. If I remove the VDEF part, it works. I have
> tried to use an other rrd file, same result.
> I'm running rrdtool on a NSLU2 unit (ARM7 cpu) using Debian. I have tried
> with the motion package in debian and also compiled the sources from the
> trunk in the SVN archive, same result.
> Have I done something wrong in this command?

I don't think so.  The same problem should occur when you try to
compute the average (this uses the same code).  Please try:


Does this hang as well?

It sounds like an endless loop, however I don't see how (and where)
this would happen.

Do you have a huge amount of rows to process, combined with a small
integer size perhaps?

Maybe you can add some debugging printf statements to the code,
look in rrd_graph.c near the end, function vdef_calc().  It would
be interesting to know if the code is reached and if it exits again.

Alex van den Bogaerdt

More information about the rrd-users mailing list