[rrd-users] VDEF hangs rrdtool

Dag Erlandsson langarod2 at gmail.com
Tue Jun 26 23:53:43 CEST 2007

It hangs with AVERAGE, MINIMUM and LAST also.

The strange thing is that if I enable the debug printf in the beginning of
vcalc_def() function, it prints out AND returns OK.
Then I tested to remove the debug printf again and now it hangs again.
Tries to add it again, and now it dosn't hang.

The debug printf prints:
DEBUG: start == 1182807840, end == 1182894480, 361 steps

So just now I'm in the situation when I add printfs to see what happens it
works, removes the dosn't work. It looks like I have to learn how to use
gdb. Can it be run on an ARM7 platform?

Best regards
Dag Erlandsson

2007/6/26, Alex van den Bogaerdt <alex at ergens.op.het.net>:
> On Tue, Jun 26, 2007 at 02:49:48PM +0200, Dag Erlandsson wrote:
> > rrdtool graph - DEF:countA=/var/owdata/temp1.rrd:temp:AVERAGE
> > VDEF:powerA=countA,TOTAL
> >
> > This command never returns. If I remove the VDEF part, it works. I have
> > tried to use an other rrd file, same result.
> >
> > I'm running rrdtool on a NSLU2 unit (ARM7 cpu) using Debian. I have
> tried
> > with the motion package in debian and also compiled the sources from the
> > trunk in the SVN archive, same result.
> >
> > Have I done something wrong in this command?
> I don't think so.  The same problem should occur when you try to
> compute the average (this uses the same code).  Please try:
> VDEF:powerA=countA,AVERAGE
> Does this hang as well?
> It sounds like an endless loop, however I don't see how (and where)
> this would happen.
> Do you have a huge amount of rows to process, combined with a small
> integer size perhaps?
> Maybe you can add some debugging printf statements to the code,
> look in rrd_graph.c near the end, function vdef_calc().  It would
> be interesting to know if the code is reached and if it exits again.
> --
> Alex van den Bogaerdt
> http://www.vandenbogaerdt.nl/rrdtool/
> _______________________________________________
> rrd-users mailing list
> rrd-users at lists.oetiker.ch
> https://lists.oetiker.ch/cgi-bin/listinfo/rrd-users
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.oetiker.ch/pipermail/rrd-users/attachments/20070626/b14c215f/attachment.html 

More information about the rrd-users mailing list