[rrd-users] Problems using a bare timespec with -s and -e

Pedro LaWrench pedrolawrench at yahoo.com
Fri Mar 2 16:12:55 CET 2007

Alex van den Bogaerdt <alex at ergens.op.het.net> wrote:  On Thu, Mar 01, 2007 at 04:02:32PM -0800, Pedro LaWrench wrote:

>   rrdtool graph /tmp/kc.png -i -s '01:15' -e '09:15' ...
>   now returns
>   ERROR: start time: the specified time is incorrect (out of range?)

Not sure if this is it, but have you tried '01\:15' ?

I cannot comment on the other question you asked (intended behaviour or not).
I  tried that, and that didn't work either.  I did try '01:15 3/2/07'  and this does work.  So it appears that the date must be specified  as well as the time of day.  Previous versions assumed the date  was today if it was omitted.  This means any script calling  rrdtool must construct today's date and include it in the  arguments.  Not real difficult, but an extra step nonetheless.

TV dinner still cooling?
Check out "Tonight's Picks" on Yahoo! TV.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.oetiker.ch/pipermail/rrd-users/attachments/20070302/ce429a49/attachment.html 

More information about the rrd-users mailing list