[rrd-users] Problems using a bare timespec with -s and -e

Alex van den Bogaerdt alex at ergens.op.het.net
Fri Mar 2 16:55:17 CET 2007

On Fri, Mar 02, 2007 at 07:12:55AM -0800, Pedro LaWrench wrote:
> Alex van den Bogaerdt <alex at ergens.op.het.net> wrote:  On Thu, Mar 01, 2007 at 04:02:32PM -0800, Pedro LaWrench wrote:
> >   rrdtool graph /tmp/kc.png -i -s '01:15' -e '09:15' ...
> >   now returns
> >   ERROR: start time: the specified time is incorrect (out of range?)
> > Not sure if this is it, but have you tried '01\:15' ?
> > I cannot comment on the other question you asked (intended behaviour or not).

> I  tried that, and that didn't work either.  I did try '01:15 3/2/07'
>  and this does work.  So it appears that the date must be specified
> as well as the time of day.  Previous versions assumed the date  was
> today if it was omitted.  This means any script calling  rrdtool must
> construct today's date and include it in the  arguments.  Not real
> difficult, but an extra step nonetheless.

Try "today".

I don't know about every change.  What I do know is that's it's very
difficult to parse time and date in every possible combination.  Order
is important ("today 12:00" vs. "12:00 today") and some numbers could
be interpreted in more than one way.

If you can create an algorithm that works in every case, let us (the
list) know and I'm sure somebody will code it.

Alex van den Bogaerdt

More information about the rrd-users mailing list