[rrd-users] memory corruption

Kiss Gabor (Bitman) kissg at ssg.ki.iif.hu
Thu Apr 10 18:00:54 CEST 2008

Dear folks,

I use Cricket.
This is the first time I tried COMPUTE ds.
The following command created the RRD file:

rrdtool create /var/lib/cricket//power/klimagepek/fh1.rrd --start 1207237409 --step 300 DS:ds0:GAUGE:600:0:1 DS:ds1:COMPUTE:1,ds0,- RRA:AVERAGE:0.5:1:600 RRA:AVERAGE:0.5:6:700 RRA:AVERAGE:0.5:24:775 RRA:AVERAGE:0.5:288:797 RRA:MAX:0.5:1:600 RRA:MAX:0.5:6:700 RRA:MAX:0.5:24:775 RRA:MAX:0.5:288:797

Then I tried to dump it manually:

$ rrdtool dump /var/lib/cricket//power/klimagepek/fh1.rrd 
<!-- Round Robin Database Dump --><rrd> <version> 0003 </version>
        <step> 300 </step> <!-- Seconds -->
        <lastupdate> 1207842250 </lastupdate> <!-- 2008-04-10 17:44:10 CEST -->

                <name> ds0 </name>
                <type> GAUGE </type>
                <minimal_heartbeat> 600 </minimal_heartbeat>
                <min> 0.0000000000e+00 </min>
                <max> 1.0000000000e+00 </max>

                <!-- PDP Status -->
                <last_ds> UNKN </last_ds>
                <value> 0.0000000000e+00 </value>
                <unknown_sec> 210 </unknown_sec>

                <name> ds1 </name>
                <type> COMPUTE </type>
*** glibc detected *** realloc(): invalid pointer: 0xbfb01af1 ***

1. I don't know if the first command creating database is correct or not.
Please help.

2. I don't know if the database is corrupted or not.
It can be found at URL http://bakacsin.ki.iif.hu/~kissg/tmp/fh1.rrd
Could you analyze it?

3. I guess rrddump should not crash but check file more strictly.
"rrdtool fetch /var/lib/cricket//power/klimagepek/fh1.rrd AVERAGE" works well.

Thanks for any hints.


More information about the rrd-users mailing list