[rrd-users] Using RRDp with ActiveState Perl 5.8 on windows xp

Joe Kane jkane at mail.com
Sun Jul 20 18:31:38 CEST 2008

I'm trying to use RDDp with ActiveState Perl 5.8 on Windows XP PRO. I'm
not quite sure I understand the prerequisites, so I hope you'll can shed
some light and bear with me. I'm surely in over my head. And yes, I'm new
to Perl, which I am installing just for this purpose. Searching far and
wide, I don't find a great deal of info relative to the Windows
XP/Perl/RRDP combination. I have VC++ 6.0 on my machine, but compiling
RRDTOOL is  beyond my expertise. (Yes, I tried, using the supplied
project files, but there are many errors).   I obtained a win32 binary
 of rrdtool 1.2.27 (latest version of a compiled windows binary that I
could find), and copied it to a location on my drive (no explicit install
required).  It runs OK from command line, I can create RRDs. The latest
win32 binaries on the download site do not seem to include pipe support.
I got the 1.2.27 full distribution, and tried to perl compile the module
using NMAKE.  After commenting out the 'fnctl' lines, and modifying the
base.t to point to the windows path of the rrdtool executable, I tried to
do NMAKE test. This hangs perl indefinitely, at '1/5', but I do see the
test rrd get created. I have to kill perl process. I did go forward with
NMAKE install for kicks, and this did appear to install to Perl/site
properly. I have some other perl scripts that essentially do the same
thing (hang sometime after the RDDp::create) Since I am using NMAKE from
VC 6.0 to compile rrdp, is there a requirement that RRDTOOL also be
compiled with VC 6.0? I guess its possible the win32 binary I am using
was compiled with something else, so I am hitting an incompatibility, or
it was not compiled with Perl support. (I'm not sure thats
applicable/relevant to RRDP pipe). If you could point me in the right
direction, or suggest how I might debug the issue, I'd appreciate it.

Be Yourself @ mail.com!
Choose From 200+ Email Addresses
Get a Free Account at www.mail.com

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.oetiker.ch/pipermail/rrd-users/attachments/20080720/2bebe8a3/attachment.html 

More information about the rrd-users mailing list