[rrd-users] fixed font sizes with rrdtool 1.3.x + cacti

nate rrdtool at aphroland.org
Wed Jan 7 23:29:58 CET 2009

I have done some searches but couldn't find much useful
info as to where the problem might lie.

I'm running RRDTool 1.3.5(upgraded in the past several of minutes
from 1.3.4) 64-bit on CentOS 5.1, with cacti 0.8.7b, previously
I was running RRDTool 1.2.23 on CentOS 4.4 with the same cacti
version. I wanted to migrate to 1.3.x because of the I/O
improvements dealing with NFS. I made the switch to the 1.3.x
code base on 12/12(had to upgrade the OS as well as 1.3.x wouldn't
build on the older OS).

With RRDTool 1.2.x the server was sustaining 200Mbit/s 24/7
most of which was NFS traffic, with 1.3.x the server is sustaining
about 4.25Mbit/s. As far as back end spindles go with 1.2.x
on my big fancy storage array it was consuming consistently
roughly 170 megabytes per second from the controllers(disk
reads, mostly cache hits the controllers have combined 24GB
of cache), after upgrading to 1.3.x, it went down to a small
fraction of that.

The server updates roughly 9600 data sources per minute in
about 750 files(15% cpu on a 8-core system). A far cry from
the rrdtool 1.0.46-based system I built several years ago
which would of needed 10x the I/O capacity that this one

Everything seems to work great, except I'd like to get real
fixed width fonts back if possible.

Example of graph taken earlier last year with rrdtool 1.2.x:

Example of graph taken a couple minutes ago with rrdtool 1.3.5:

Specifically note how the legend lines up cleaner in the graph
generated by 1.2.

The one thing to note is I did have to override the build
depends when compiling it as CentOS 5.1 still doesn't quite
meet the requirements:

cairo-devel >= 1.4.6 is needed by rrdtool-1.3.5-1.el5.x86_64
pango-devel >= 1.17 is needed by rrdtool-1.3.5-1.el5.x86_64

I have:

I'm not sure if that would impact this or not. I tried
playing around a bunch with the font path and stuff(under 1.3.4,
haven't tried 1.3.5) but wasn't able to get good results, no
matter what I tried it seemed to pick the same font. I'm sure
I was doing a bunch of stuff wrong, despite having been using
rrdtool pretty extensively for the past 5 years or so there's
still a lot that eludes me.

I did notice some minor font change going from 1.3.4 to 1.3.5,
looks related to the changelog about cacti's titles.



More information about the rrd-users mailing list