[rrd-users] RRDs not loadable

Matt Sheridan mattmail5050 at gmail.com
Mon Nov 2 17:09:03 CET 2009

All – I have struggled getting RRDs to be loadable. I have searched this
mailing list and attempted every related suggestion I can, and I still
cannot get it to work. I would be very grateful for your help. Here is the

I have a RHEL6 64 bit server running apache. Perl v 5.8.8. I am attempting
to install a software package that uses Perl/RRDs.

I install RRDs (multiple versions now) using the following:

   tar -zxvf rrdtool-x.x.x.tar.gz

   cd rrdtool-x.x.xx

   ./configure --prefix=/usr/local/rrdtool --enable-perl-site-install
--disable-tcl (I have tried a few variations, including a plain ./configure)


   make install

(I have also tried make install site-per-install)

As far as I can tell, the compilation and installation are successful. No
errors at the end of make/install. have also tried several  versions of rpm
packages. Https restarted, rebooted, etc.

Reading through the configure.log, I do see a few errors, I will append them

When I attempt to pull up the related pl script in my browser I get the

Can't locate RRDs.pm in @INC (@INC contains:
/usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl
/usr/lib/perl5/vendor_perl /usr/lib64/perl5/5.8.8/x86_64-linux-thread-multi
/usr/lib/perl5/5.8.8 .) at /var/www/cgi-bin/CUGrapher.pl line 16., referrer:

Of course, RRDs.om IS in that location – I have checked and double checked.
Here it is:

[root at ncldl38008 ~]# ls -l

total 92

drwxr-xr-x 26 root   root  4096 Nov  2 09:59 auto

-r--r--r--  1 root   root 29621 Sep 28  2005 Cflow.pm

drwx------  3 root   root  4096 Oct  8 09:58 Compress

drwx------  2 root   root  4096 Oct  8 10:09 Digest

drwx------  2 root   root  4096 Oct 30 14:44 Net

-r--r--r--  1 root   root  1215 Dec 18  2005 ntmake.pl

-rw-------  1 root   root   442 Oct 30 18:01 perllocal.pod

-r-xr-xr-x  1 apache root  3813 Dec 18  2005 RRDs.pm

drwx------  2 root   root  4096 Oct  8 10:02 Term

drwx------  2 root   root  4096 Oct 30 17:13 version

-r--r--r--  1 root   root  2327 Oct 30 17:13 version.pm

-r--r--r--  1 root   root 12315 Oct 30 17:13 version.pod

As you can see, I have changed the permissions to apache (A desperate hack).

I have also noticed that perl DOES seem to SEE RRDs.pm, given that when I
move the file RRDs.pm to another name, I get a separate error indicating
that it cant find RRDs.pm. This indicates to me that perl can see RRDs.pm,
but for some reason it is failing to process it appropriately.

Like I said, I have tried so many variations of hacks here. Ive added lines
to the perl script to include lib paths, temporarily added lines to @INC,
etc. I am very eager for any help that might actually get this perl script
to run. Just so you can see it, here is the first few lines of the perl


# CUGrapher.pl

# $Revision: 1.53 $

# Author: Matt Selsky <selsky at columbia.edu>

# Contact for help: <cuflow-users at columbia.edu>

# (c) 2002 - 2005 The Trustees of Columbia University in the City of New

# License restrictions apply, see COPYING for details.

use strict;

use CGI::Pretty qw(-nosticky :standard);

# use lib qw( /usr/local/rrdtool/lib/ ../lib/perl );

use RRDs;   ## <- This is where it croaks

use Digest::MD5 qw(md5_hex);

### Local settings ###

# directory with rrd files


Config.log errors (none seem to kill the process, and the end indicates

conftest.c:2: error: expected '=', ',', ';', 'asm' or '__attribute__' before

configure:2970: $? = 1

configure: failed program was:

| #ifndef __cplusplus

|   choke me

| #endif

configure: failed program was:

| /* confdefs.h.  */


| #define PACKAGE_NAME "rrdtool"

| #define PACKAGE_TARNAME "rrdtool"

| #define PACKAGE_VERSION "1.2.12"

| #define PACKAGE_STRING "rrdtool 1.2.12"


| #define PACKAGE "rrdtool"

| #define VERSION "1.2.12"


| /* end confdefs.h.  */

| #include <ac_nonexistent.h>

conftest.c:12:28: error: ac_nonexistent.h: No such file or directory

configure:3468: $? = 1

configure: failed program was:

| /* confdefs.h.  */

configure: failed program was:

|       program main

| #ifndef __GNUC__

|        choke me

| #endif


|       end

configure:5478: result: no

configure:5484: checking whether  accepts -g

configure:5496:  -c -g conftest.f >&5

./configure: line 5497: -c: command not found

configure:5502: $? = 127

configure: failed program was:

|       program main


In the end:

#ifdef __cplusplus

extern "C" void std::exit (int) throw (); using std::exit;

configure: exit 0

Make/Make install all indicate success.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.oetiker.ch/pipermail/rrd-users/attachments/20091102/0253d024/attachment.htm 

More information about the rrd-users mailing list