[rrd-users] Bug in rrdtool?

Jean-Yves Avenard jyavenard at gmail.com
Fri Jan 1 07:14:46 CET 2010


2010/1/1 Benny Baumann <BenBE at geshi.org>:
> Which version of RRDTool on what platform using which OS were you using?

I tried RRDtool 1.4.2 and 1.3.9.
That was on a Ubuntu 9.10 / 64 bits Linux (2.6.31)

> ow was the interfacing with RRDTool (I'd guess Command Line client from
> the source below)?
> Is the error reproduceable? If so, to what extend? Could you provide the
> offending RRD Database or does it happen with every file of a given format?

Yes, I can reproduce it every time ...

It was created with:
rrdtool create solarprod.rrd -s 60 \
DS:power:GAUGE:300:0:U \
DS:total:DERIVE:300:0:U \
RRA:AVERAGE:0.5:1:144000 \
RRA:AVERAGE:0.5:5:525600 \
RRA:AVERAGE:0.5:30:87840 \
RRA:AVERAGE:0.5:60:43920 \
RRA:AVERAGE:0.5:120:21960 \
RRA:AVERAGE:0.5:1440:1830 \
RRA:MIN:0.5:60:43920 \

> Could you check with a debugger to get some more specific information
> about the issue?

I've now completely changed the way I was doing it ; because I
couldn't bypass that problem otherwise.

So what I now do instead of getting rrdtool to graph ; is calling in
my php script rrdtool fetch on all the period I'm interested ; then I
do the calculation myself and add the string in the graph.

> hmmm, usuaklly notihing to worry about ...

I would have thought so :)

> Hmmm, maybe you might want to try the direct PHP bindings for PHP for
> faster interfacing with RRDTool without needing process execution for
> PHP to be enabled (improving security).

I had trouble compiling the PHP module on FreeBSD ; so I found it
easier and more portable to exec on the rrdtool binary.

> Could you provide the full command line that is being executed when the
> problem appears?

I don't have it anymore ... The PHP code there generate the command line.

> Please try
> "CDEF:cext=cext0,cext1,cext2,+,+"

I had tried that already ; it made no difference.

I also tried splitting the calculation in two CDEFs then add those
CDEF together ; I got the same error.

> Plese provide a small testcase script+rrd file that gives this error.
> Instead of the rrdfile you could also provide a create statement for
> such a file.

I'll try again a bit later ; I'm more interest in fixing the '??'
error in the graph right now (see other thread) , because for that one
I have no work around...


More information about the rrd-users mailing list