[rrd-users] Bug in rrdtool?

Benny Baumann BenBE at geshi.org
Fri Jan 1 13:01:56 CET 2010

Am 01.01.2010 07:14, schrieb Jean-Yves Avenard:
> Hi
> 2010/1/1 Benny Baumann <BenBE at geshi.org>:
>> Which version of RRDTool on what platform using which OS were you using?
> I tried RRDtool 1.4.2 and 1.3.9.
> That was on a Ubuntu 9.10 / 64 bits Linux (2.6.31)
I'll hand over the fixing to someone with such a system, as they can
detail this better ...
>> ow was the interfacing with RRDTool (I'd guess Command Line client from
>> the source below)?
>> Is the error reproduceable? If so, to what extend? Could you provide the
>> offending RRD Database or does it happen with every file of a given format?
> Yes, I can reproduce it every time ...
> http://www.avenard.org/files/solarprod4.rrd.bz2
> It was created with:
> rrdtool create solarprod.rrd -s 60 \
> DS:power:GAUGE:300:0:U \
> DS:total:DERIVE:300:0:U \
> RRA:AVERAGE:0.5:1:144000 \
> RRA:AVERAGE:0.5:5:525600 \
> RRA:AVERAGE:0.5:30:87840 \
> RRA:AVERAGE:0.5:60:43920 \
> RRA:AVERAGE:0.5:120:21960 \
> RRA:AVERAGE:0.5:1440:1830 \
> RRA:MIN:0.5:60:43920 \
> RRA:MAX:0.5:60:43920
Let's see if I can reproduce this on Debian (but usually should if
Ubuntu breaks)
>> Could you check with a debugger to get some more specific information
>> about the issue?
> I've now completely changed the way I was doing it ; because I
> couldn't bypass that problem otherwise.
> So what I now do instead of getting rrdtool to graph ; is calling in
> my php script rrdtool fetch on all the period I'm interested ; then I
> do the calculation myself and add the string in the graph.
hmmm, It's a way, but let's see if the usual way can be made working too ;-)
>> hmmm, usuaklly notihing to worry about ...
> I would have thought so :)
Nice to know ^^
>> Hmmm, maybe you might want to try the direct PHP bindings for PHP for
>> faster interfacing with RRDTool without needing process execution for
>> PHP to be enabled (improving security).
> I had trouble compiling the PHP module on FreeBSD ; so I found it
> easier and more portable to exec on the rrdtool binary.
Which version were you trying? There's some REALLY old binding which
makes some trouble and a more recent one (I updated a few months ago to
include some more functions). Would be nice to get some feedback on the
compiling issues of the extension so I can fix them. Usually the new
extension should be compileable as a without much ado (once you have all
the necessary headers installed).
>> Could you provide the full command line that is being executed when the
>> problem appears?
> I don't have it anymore ... The PHP code there generate the command line.
>> Please try
>> "CDEF:cext=cext0,cext1,cext2,+,+"
> I had tried that already ; it made no difference.
> I also tried splitting the calculation in two CDEFs then add those
> CDEF together ; I got the same error.
hmmm, seems something inside the parser goes wrong ...
>> Plese provide a small testcase script+rrd file that gives this error.
>> Instead of the rrdfile you could also provide a create statement for
>> such a file.
> I'll try again a bit later ; I'm more interest in fixing the '??'
> error in the graph right now (see other thread) , because for that one
> I have no work around...
NP. One bug at a time ... but properly ;-)
> Jean-Yves

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 833 bytes
Desc: OpenPGP digital signature
Url : http://lists.oetiker.ch/pipermail/rrd-users/attachments/20100101/32a3980c/attachment.pgp 

More information about the rrd-users mailing list