[rrd-users] Default font is not used

Victor Engmark victor.engmark at gmail.com
Mon Feb 28 17:36:47 CET 2011


I've tried to compile rrdtool (with pangocairo + fontconfig etc.) with
lots of different options, but I can't figure out how to make it use
the font I've provided. Whenever I run `rrdtool graph` it complains:

(process:18744): Pango-WARNING **: failed to choose a font, expect
ugly output. engine-type='PangoRenderFc', script='common'

The resulting PNG file contains rectangles instead of characters.
Apropos, specifying .svg instead of .png still results in PNG file

I've compiled using
--with-freetype-config=/usr/opt/rrdtool/share/fonts/VeraMono.ttf, and
I've verified that that path exists and is readable after
installation. Please note that this is a custom minimal Linux
platform, so standard packaging systems (apt-get, emerge, yum) do
*not* apply.

Possible issues:
* Do I *have* to have a fontconfig configuration file for this font?
`/usr/opt/cairopango/bin/fc-cache -fv /usr/opt/rrdtool/share/fonts/`
says "
/usr/opt/rrdtool/share/fonts: caching, new cache contents: 1 fonts, 0
dirs", but I still get the same message afterwards.

Victor Engmark

More information about the rrd-users mailing list