[rrd-users] Stuck with rrdjig tool

Kurt Swinkels rrdtool at kswinkels.nl
Tue Jun 5 21:06:00 CEST 2012

Hi there,

I'm trying to use this tool to merge several rrd databases. I'm working on a
home temperature project. I'm using OpenWrt on a TP Link1043ND router. The
number of (1-wire) sensors is increasing from to time to time and I also like to
use a different rrd db structure (more samples). So rrdjig looks like the
perfect tool.

I ran into some trouble. I tried to use rrdjig on OpenWrt but Perl some is
missing some module:  RRDs.pm

Convinced getting it to work on OpenWrt was too difficult I set up an Ubuntu VM
and tried it with exported rrd DB's. Module problem solved but now I get the

Constantly looping this:
Use of uninitialized value in numeric le (<=) at ./rrdjig.pl line 196.

Command line: 
./rrdjig.pl tempproj.old.rrd tempproj.old2.rrd

Running the latest:

I read the help information but I'm not sure what's meant by templates.

Any help or tip is appreciated.


More information about the rrd-users mailing list