[rrd-users] Stuck with rrdjig tool

Tobias Oetiker tobi at oetiker.ch
Tue Jun 5 23:52:26 CEST 2012

Today Kurt Swinkels wrote:

> Hi there,
> I'm trying to use this tool to merge several rrd databases. I'm working on a
> home temperature project. I'm using OpenWrt on a TP Link1043ND router. The
> number of (1-wire) sensors is increasing from to time to time and I also like to
> use a different rrd db structure (more samples). So rrdjig looks like the
> perfect tool.
> I ran into some trouble. I tried to use rrdjig on OpenWrt but Perl some is
> missing some module:  RRDs.pm
> Convinced getting it to work on OpenWrt was too difficult I set up an Ubuntu VM
> and tried it with exported rrd DB's. Module problem solved but now I get the
> following:
> Constantly looping this:
> Use of uninitialized value in numeric le (<=) at ./rrdjig.pl line 196.
> Command line:
> ./rrdjig.pl tempproj.old.rrd tempproj.old2.rrd
> Running the latest:
> http://oss.oetiker.ch/rrdtool-trac/browser/trunk/contrib/rrdjig/rrdjig.pl
> I read the help information but I'm not sure what's meant by templates.

hallo kurt,

the purpose of rrdjig is to modify the resolution of an existing
rrd database by putting it's content into a freshly created empty
rrd file ... it does no do any merging ...


> Any help or tip is appreciated.
> Regards,
> Kurt
> _______________________________________________
> rrd-users mailing list
> rrd-users at lists.oetiker.ch
> https://lists.oetiker.ch/cgi-bin/listinfo/rrd-users

Tobi Oetiker, OETIKER+PARTNER AG, Aarweg 15 CH-4600 Olten, Switzerland
http://it.oetiker.ch tobi at oetiker.ch ++41 62 775 9902 / sb: -9900

More information about the rrd-users mailing list