[rrd-users] RRDtool 1.4.7 on CentOS 5, SVG text does not render properly

FloydATC floyd at atc.no
Tue Mar 18 18:20:43 CET 2014

RRDtool 1.4.7 was installed from rpmforge along with cairo and pango. If I
render as PNG, everything looks fine. If I render as SVG, the text does not
appear. If I render using a ridiculously large font (like 70pt, see below) I
see some artifacts that look as if the characters are trying to hide behind
background colored boxes but their toes are showing.

The SVG renders exactly the same way in Firefox and Chrome.

I've tried downloading the newest rrdtools package and compiled it against
the newest devel packages of cairo and pango, the result is exactly the

No error messages btw, and I've tried several fonts listed in 'fc-list'.

Has anyone managed to get this to work, or should I just give up and
generate my own SVG files based on 'rrdtool fetch' instead of wasting any
more time?


View this message in context: http://rrd-mailinglists.937164.n2.nabble.com/RRDtool-1-4-7-on-CentOS-5-SVG-text-does-not-render-properly-tp7581838.html
Sent from the RRDtool Users Mailinglist mailing list archive at Nabble.com.

More information about the rrd-users mailing list